MYPin PID Temp Controller?

HomeBrewTalk.com - Beer, Wine, Mead, & Cider Brewing Discussion Community.

Help Support Homebrew Talk:

JRems

Well-Known Member
Joined
Nov 18, 2010
Messages
2,186
Reaction score
65
Location
Mahopac
I think this same one has been discussed here before. I don't think it has a manual mode which is used for the boil.
 

pvtschultz

Well-Known Member
Joined
Feb 11, 2010
Messages
457
Reaction score
9
Location
New Berlin
I have that unit in my eBIAB keggle setup. It works fine as a temperature controller, but as others have mentioned, it does not have a "manual" mode to control the boil intensity. I ended up building a PWM circuit to handle that duty, but for the same price you could buy the Auber unit and not go through all the hassle. It would work plenty well for a eHERMS setup though but you'll need to do something different for boil.
 

rdcamps

New Member
Joined
Apr 9, 2012
Messages
1
Reaction score
0
Location
woodridge
Hi,

I am a new member and don't know much about PIDs. I am also not into brewing but do need help regarding installing a temperature controller for the purpose of maintaining an accurate temperature of my photographic chemicals while processing films. I hope anyone could help me even though I am not a brewer. I purchased a MYPIN TA8-SNR+K and an OMRON SSR 5-24V input/24-240V load. I tried following the circuit diagram provided for the controller. Wired the power supply ok, wired the thermocouple ok (I have temperature readings) then followed the parameter setting procedure and set my target temp to 37.8 C. Problem is when I tried to wire the SSR. I wired the input terminals of SSR to controller output1 which is labeled as terminals 7&8 taking care of polarity. I then wired a test lamp to the SSR output terminals. When I turn on the power supply, I can see the pilot lamp (not the test lamp I connected) of the SSR light up but the test lamp I connected does not light up. I then tried to connect my heater (a griddle without the thermostat) to the SSR instead of the test lamp but the heater is not being powered up. The test lamp should have lighted or the the heater should have powered up upon turning on the power supply because the default state of the temp control SSR output is ON, right? Am I doing something wrong with my wiring? I just need to set up a temperature controlled water bath (A 4" x 14" x 14" tray) and immerse by bottles of chemicals. It is a simple setup and think a very expensive temp controller would be overkill. The MYPIN controller's price is just about right for me. Thanks for any help you could offer.
 

tcw126

Member
Joined
Mar 2, 2012
Messages
6
Reaction score
0
Location
Collegeville

Walker

I use secondaries. :p
Lifetime Supporter
Joined
Sep 8, 2005
Messages
10,982
Reaction score
113
Location
Cary
Anybody got a manual for the mypin TA4? My buddy bought one and we put together his RIMS system over the past week, but he didn't get a manual.

I managed to figure out how to get into the programming mode and configure the type of probe and sent the P,I,and D parameters. But what I don't know is which parameter corresponds to the temp probe error. We need to adjust that, and don't know which item that is in the menu.
 

t0rin0

Member
Joined
Jul 10, 2010
Messages
19
Reaction score
1
Location
La Verne
Sorry to bump a really old thread but I just bought one of these things on Amazon and I can't for the life of my find any documentation. Did anyone happen to download/save that link while it was still active?
 

t0rin0

Member
Joined
Jul 10, 2010
Messages
19
Reaction score
1
Location
La Verne
Thanks! :ban:

Also found some youtube videos of a similar model (7A instead of the 4A, has a second alarm and some other features) that got me started. Just need to go buy a relay and I'll be ready to start assembly. This particular one is for making yogurt and cheese but once I get it figured out I'm going to rig something similar for sour mashing.
 

Latest posts

Top