TiltBridge - Tilt-to-WiFi Device for Tilt Hydrometer

Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum

Help Support Homebrew Talk:

OP
OP
T

Thorrak

Supporting Member
HBT Supporter
Joined
Feb 7, 2016
Messages
3,157
Reaction score
2,079
Location
New York, NY
I finally got it
I found that with the last redesign, they put that under Extensions > Apps Script
I still had issues but found an answer in being logged into multiple Google accounts. I had to log onto the proper account in chrome and I was able to get it set up. I also had to install the Bonjour for Print Services to access the tiltbrige.local page. I had to be logged into the proper account to set up a new log as well, even though I can access tiltbridge.local from a different account. Thanks again Thorrak for this great app!

Oof - Sorry that you had to go searching! It seems like every so often Google can't help but hide that option somewhere new. :(
 

Henbrew

Supporting Member
HBT Supporter
Joined
Apr 18, 2017
Messages
114
Reaction score
122
Location
Macungie
Got everything sorted out it seems and connected to Brewersfriend 👍

1643639910762.png
 

RocketBrewer

Well-Known Member
Lifetime Supporter
Joined
Feb 26, 2012
Messages
565
Reaction score
198
Location
Garden Valley, CA
Help?? After getting TiltBridge to work on a plain ESP32 board with minimal problems, I decided to upgrade to an OLED board so I could have readings displayed all the time. I set up the Heltec board and started the flashing but after about 15 minutes, it still says "Erasing". The first board didn't take anywhere near that much time. I'm afraid to try to do anything for fear of Bricking my new controller. Am I screwed? What can I do?
 
OP
OP
T

Thorrak

Supporting Member
HBT Supporter
Joined
Feb 7, 2016
Messages
3,157
Reaction score
2,079
Location
New York, NY
Help?? After getting TiltBridge to work on a plain ESP32 board with minimal problems, I decided to upgrade to an OLED board so I could have readings displayed all the time. I set up the Heltec board and started the flashing but after about 15 minutes, it still says "Erasing". The first board didn't take anywhere near that much time. I'm afraid to try to do anything for fear of Bricking my new controller. Am I screwed? What can I do?

Just unplug it. You'll be fine.
 
OP
OP
T

Thorrak

Supporting Member
HBT Supporter
Joined
Feb 7, 2016
Messages
3,157
Reaction score
2,079
Location
New York, NY
Thanks Thorrak! It worked on the second try. I was afraid to try to stop it for fear it might leave it bricked

Nah. There's a few sections of the chip where a bad write might cause issues, but the most likely outcome is that you end up with a chip that isn't capable of booting & needs to be reflashed. Since you're using another device (a computer) to flash it in the first place, that's more of an annoyance than something potentially catastrophic. It's much more of a problem if doing an "over the air" update where the device is updating itself, and may not be able to fix itself if the update fails.

Glad to hear it is up and running! Let me know if you have any issues/questions. :)
 

RyanWeary

Well-Known Member
Joined
Jan 3, 2010
Messages
138
Reaction score
11
Location
Ft. Worth, TX
I've been having a heck of time getting this to work. I'm stuck at the beginning. I can't even flash the firmware using Brewflasher. I get a variety of errors:

esptool.py v3.2
Serial port COM4
Connecting......................................
Firmware flashing FAILED. esptool.py raised an error.
Try flashing again, or try flashing with a slower speed.

or

Serial port COM4
Connecting......................................
COM4 failed to connect: Failed to connect to ESP32: No serial data received.
For troubleshooting steps visit: GitHub - espressif/esptool: Espressif SoC serial bootloader utility

When I connect the device to my PC, Windows makes that sound like it recognized a USB device being plugged in.

For the record, I bought the LOLIN D32 Pro (16MB with LED because that's all that was in stock) with the LOLIN TFT-2.4 with the connecting cable.

The D32 Pro has a red light next to a button that remains on, pressing the button doesn't seem to do anything. When plugged in the screen will stay lit - but doesn't read anything.

HELP!!!
 

RyanWeary

Well-Known Member
Joined
Jan 3, 2010
Messages
138
Reaction score
11
Location
Ft. Worth, TX
Are you sure your USB cable has a data line? Some cables are power only. Some are power and data. (That would be the first place to start)
Well holy cow - you're right! We don't have many micro USB cables laying around - but the last one I had worked! Thanks! I thought after trying the first two cables it was a problem with the board. Glad I'm wrong. I appreciate the tip!
 

ksmax

New Member
Joined
Feb 23, 2022
Messages
4
Reaction score
0
I have the Lolin d32 Pro and the HiLetgo 2.4" TFT display. Can someone help me identify the cable I need to connect the two? I have tried several searches of the forum and didn't have any luck. Ideally I would like to order it from Amazon. The site linked in the hardware documentation doesn't arrive until late April and the shipping is horrible.

Thanks

Kevin
 
OP
OP
T

Thorrak

Supporting Member
HBT Supporter
Joined
Feb 7, 2016
Messages
3,157
Reaction score
2,079
Location
New York, NY
I have the Lolin d32 Pro and the HiLetgo 2.4" TFT display. Can someone help me identify the cable I need to connect the two? I have tried several searches of the forum and didn't have any luck. Ideally I would like to order it from Amazon. The site linked in the hardware documentation doesn't arrive until late April and the shipping is horrible.

Thanks

Kevin
Do you have a link to the TFT display?

Unfortunately, I don't think other vendor's displays are compatible with the D32 pro.
 

ksmax

New Member
Joined
Feb 23, 2022
Messages
4
Reaction score
0
OP
OP
T

Thorrak

Supporting Member
HBT Supporter
Joined
Feb 7, 2016
Messages
3,157
Reaction score
2,079
Location
New York, NY
If you're referring to this display, then unfortunately there is no cable you can purchase off the shelf to connect the two. They can be connected, but you would need to figure out the pinout from the D32 Pro's LCD display connector, match it up against the corresponding pins of that display, and then design a PCB/cable yourself to connect the two.
 

Jeffmyers5266

Member
Joined
Sep 28, 2018
Messages
12
Reaction score
1
Hi everyone,

Looking for some help with my TiltBridge setup. I’ve downloaded BrewFlasher and installed firmware recommended by someone earlier in this thread. It now finds COM4 since installing the firmware, but it just stops after downloading it. No errors or anything. I’ve let it go for hours with no update. Is there something I’m supposed to be doing to get it to actually install? I’ve tried both erasing and not erasing the data.
 

Attachments

  • CC48EF02-001F-414C-BCBF-A95EA695332F.jpeg
    CC48EF02-001F-414C-BCBF-A95EA695332F.jpeg
    1 MB · Views: 11

Exception13

Well-Known Member
Lifetime Supporter
Joined
Oct 9, 2012
Messages
166
Reaction score
110
Location
Westport, Ontario
Is there something I’m supposed to be doing to get it to actually install? I’ve tried both erasing and not erasing the data.

First thing to confirm is your USB cable as mentioned above. Have you confirmed it is a data/power cable and not just power only? That caught me when I built mine last year.

Hope that helps.

Chris
 

Jeffmyers5266

Member
Joined
Sep 28, 2018
Messages
12
Reaction score
1
First thing to confirm is your USB cable as mentioned above. Have you confirmed it is a data/power cable and not just power only? That caught me when I built mine last year.

Hope that helps.

Chris

I’ve tried a few, most don’t show up with anything under Serial Port, but two of them do. Neither moves past where I got in the screen shot. In the device manager, it shows as the most up to date firmware but also “can’t verify digital signature”. I assume that’s not a problem?
 
OP
OP
T

Thorrak

Supporting Member
HBT Supporter
Joined
Feb 7, 2016
Messages
3,157
Reaction score
2,079
Location
New York, NY
I’ve tried a few, most don’t show up with anything under Serial Port, but two of them do. Neither moves past where I got in the screen shot. In the device manager, it shows as the most up to date firmware but also “can’t verify digital signature”. I assume that’s not a problem?
"Can't verify digital signature" is weird - that would imply that the firmware you downloaded isn't the firmware that you intended to download. This could be indicative of a man-in-the-middle type attack -- but the more likely scenario is that it just isn't properly downloading. You might want to try BrewFlasher Web Edition and see if that works for you.
 

Cb9880

Member
Joined
Jul 18, 2019
Messages
5
Reaction score
2
So I am having an issue with my tilt bridge. I cannot get it to log on google sheets. I have use it successfully in the past but this time it will not upload data.
 

Jeffmyers5266

Member
Joined
Sep 28, 2018
Messages
12
Reaction score
1
"Can't verify digital signature" is weird - that would imply that the firmware you downloaded isn't the firmware that you intended to download. This could be indicative of a man-in-the-middle type attack -- but the more likely scenario is that it just isn't properly downloading. You might want to try BrewFlasher Web Edition and see if that works for you.

Just wanted to update that I did finally get this working. I had been using brewflasher, but on an old windows 7 laptop. When I tried my wife’s Mac, it worked perfectly.

Also when setting up google sheets, it seemed like I needed to go through the full process from the beginning, instead of using the one I had been with the tilt app.

Hopefully this helps someone else in the future. Thanks for your help and I will say this is 1000x more convenient than using that app with an old iPhone!
 
Top