Tilt calibration problem

Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum

Help Support Homebrew Talk:

beernutz

Well-Known Member
Joined
Dec 5, 2007
Messages
1,690
Reaction score
720
Two brews ago I calibrated my Tilt hydrometer in water using TiltPi interface because it seemed off. There was a .032 difference between the uncalibrated SG (1.032) and the calibrated water SG (1.000).

After that on my next to last brew in July the OG seemed accurate as it was within a couple hundred points of what a floating hydrometer measured (1.063 vs 1.061) however the FG on the Tilt was in the low 1.020s while the FG on the floating hydrometer read 1.013.

On my last batch a couple weeks ago I have the same pattern where the 1.066 OG was the same on the Tilt and on the floating but the Tilt has leveled off at 1.024 while the floating is reading 1.014. I pulled out the Tilt and checked it in water and it shows 1.000 then I put in back in the fermenter and it is showing 1.026 which is a pretty big difference from 1.014.

I'm curious if other Tilt users have experienced similar behavior. I sent basically the above info to tilt customer support but haven't heard back yet.
 

myndflyte

Well-Known Member
Joined
Aug 27, 2014
Messages
1,330
Reaction score
594
Location
Lake Mills
Yup. I don't rely on the Tilt to tell me what the actual final gravity is but instead use it to monitor overall fermentation progress. The Tilt FG is always higher than what I measure with the hydrometer.
 
OP
beernutz

beernutz

Well-Known Member
Joined
Dec 5, 2007
Messages
1,690
Reaction score
720
I've seen weird behavior that was cleared up with a new battery.
Good idea. I will try a new battery but I just put a new one in about 6 months ago and the previous one had lasted two years.
 

centralpabrewer

Supporting Member
HBT Supporter
Joined
Sep 1, 2007
Messages
191
Reaction score
11
I have found that if you have an aggressive fermentation, yeast and troob will collect on the top of the tilt and throw it off as well.
 

matt_m

Supporting Member
HBT Supporter
Joined
Oct 6, 2017
Messages
1,071
Reaction score
485
Just had almost the same thing happen with one of mine reading significantly lower than 1.000 in Starsan. I know it still had the original battery because I have a box of a different brand. Changed it out and it was dead on accurate at 1.000.
 

cani0501

Member
Joined
Jun 11, 2013
Messages
24
Reaction score
9
I'm having an issue with the tilt2 hydrometer where the o.g. of my wort measured with a refractometer and a traditional glass hydrometer both measured it at 1.069 but when I drop the tilt in it reads 1.053! I then took the tilt out, put it in r.o. water in a pint glass and it measured 1.000. Okay, I thought, its reading the water right! The battery indicates it's okay by way of the 3 flashing green lights. Any one else have this problem? It used to work but the past 3 batches it's been absolutely useless.
 

matt_m

Supporting Member
HBT Supporter
Joined
Oct 6, 2017
Messages
1,071
Reaction score
485
Only calibrating at 1.000 isn't very meaningful as the calibration is not linear. No way they could build that correction in since each new battery changes it due to varying weights. Calibrate at 1, calibrate at your OG and it will work great. Just do it every brew day--takes an extra 30s.

Also, I found a glass can be iffy as the Tilt can be affected by hitting one or both sides. I toss it in my starsan bucket.
 

Knightshade

Which way is up again??
Lifetime Supporter
Joined
Mar 31, 2020
Messages
856
Reaction score
895
Location
SoCal
Seeing this thread makes me feel a little better. I'm using a tilt for the first time, and it measured .004 lower SG, and the FG kind of had me going is that even possible. US-05 with a 92.66 attenuation...yeesh.

I'll be interested to see how it measures out when I go to rack it next weekend.
 
Top