Quantcast

march pump

HomeBrewTalk.com - Beer, Wine, Mead, & Cider Brewing Discussion Community.

Help Support Homebrew Talk:

docmoran

Well-Known Member
Joined
May 5, 2008
Messages
132
Reaction score
2
man I am bummed -- can anyone help. did my first ag today after many many many trial runs with system/ water -- ran my boiling wort through march pump into therminator and out like a gem. Ten minutes later for clean up pump wont pump - runs but no pumping?? did I burn 125 bucks in one brew?? what do - is this normal -- do I take it apart ?? help please.
 

Bobby_M

Vendor and Brewer
HBT Sponsor
Joined
Aug 3, 2006
Messages
24,785
Reaction score
3,446
Location
Whitehouse Station
Did you use any whole hops? They could have gotten lodged in the impeller/pump head. Taking it apart is not a big deal. Are you sure it's not just airlocked and needs priming?
 
OP
D

docmoran

Well-Known Member
Joined
May 5, 2008
Messages
132
Reaction score
2
just blew backwards with baster and it went fine -- your right - blocked with debris -- of to the races again thanks
 

FireBrewer

Assistant Brewer
Joined
May 31, 2007
Messages
1,962
Reaction score
14
Location
Fallston
just blew backwards with baster and it went fine -- your right - blocked with debris -- of to the races again thanks
If you're using a pump and a plate chiller, you want to take some steps to prevent debris from getting in either (especially in the chiller).
 

noisy123

Well-Known Member
Joined
Jun 4, 2008
Messages
565
Reaction score
2
Location
Madison, WI
If you're using a pump and a plate chiller, you want to take some steps to prevent debris from getting in either (especially in the chiller).
Yes. Like this:
Hop Filter
I used it for two brews this weekend (pellet and whole hops). I used to have clogging problems with my gravity-fed CFC. No longer.
 
Top