Co2 stuck in regulator...?

Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum

Help Support Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Active Member
Feb 17, 2010
Reaction score
Got a kegerator conversion kit from KegCowboy and I am having problems with the dual-gauge regulator. When I turn on the Co2 both gauges respond correctly so pressure is def. making it in there, but it does not seem to make it to the hoses. I took off the hoses to make sure there wasn't a blockage in there and I still get nothing coming out. I have done trial and error with every valve and shut off on the thing, but no luck. Please help! Thanks!:confused:

Here is a link to the exact kit I have.
Fairly new to all this, but I assume you mean the red knob with a + and - sign?
Yes it is open. When I first connected it, it was turned almost all the way to the plus which caused a horrible sputtering noise when I opened the Co2 tank so I turned it down towards the minus. It seems to adjust the pressure of the keg (if there was any pressure getting to my keg!). The more I turn it to the plus, the higher the PSI goes.
I adn't looked at the link you posted, but you only have a single (gauge) regulator. One of your gauges read the tank level, the other should show the pressure going in to the lines. The one sticking out on the side with the red area is going to be the tank level gauge. What are the pressure readings on the gauges? When you say the CO2 isn't making it into the hoses, do you have the grey disconnects on them? Have you tried putting the disconnects on to a keg? There is a little black peg inside the disconnect that gets pushed in when connected to a keg to allow the CO2 to flow. Have you tried opening the tank without the hoses connected to see if anything is coming out of the valves?
Yeah, I did the sputtering thing once. oops! Thank God for the blow-off valve!
You're obviously getting pressure at the guages. I assume you have the shutoff valve(s) open (inline with the valve/hose). If all is correct, maybe you should take a look at the shutoffs and make sure there isn't a problem with the check valves or something. I wonder if they might have gotten stuck somehow.
Have you opened the valves on the bottom? The little red handes before it goes out to the kegs.
Since neither line is working, the problem is either the regulator itself or the Y-connector. Try removing the Y and see if there's flow. Bad regulators do get shipped.
its possible to damage a regulator by turning on the CO2 valve while the regulator valve is open. the regulator should always be closed before turning the CO2 valve open.

that sputtering is the valve/membrane flapping around violently.
Found problem - KegCowboy sent me a regulator with a small washer between the manifold and the regulator itself - problem is there was no whole in the washer! just a solid piece of circular plastic preventing any air movement from regulator to manifold. They clearly did NOT test this thing before sending it to me. I have had an overall bad experience with KegCowboy.

Thanks anyway for the suggestions :D
Its not all that bad. I know nothing about kegcowboy, but unless they screwed something else up it doesn't seem that bad.