SP-10 issues - Home Brew Forums
Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > SP-10 issues
Cool Brewing Giveaway - Supporting Membership Drive & Discount

Reply
 
Thread Tools
Old 03-02-2011, 09:52 PM   #1
MashTun-Kutcher
Recipes 
 
Jan 2011
Vancouver, Washington
Posts: 70


I bought a bayou sp10 on amazon.com but it doesnt seem to work. The stand and burner itself look brand new but the braided propane cord/regulator look used. When i light the burner, it burns a small flame for a few seconds and then lets out a "POOF" sound and the small flame is gone. Has anyone had this issue before? I really dont want to send it all the way back. Any help would be appreciated.



 
Reply With Quote
Old 03-02-2011, 10:01 PM   #2
Hethen57
Recipes 
 
Feb 2010
North Idaho
Posts: 132
Liked 3 Times on 2 Posts


Sometimes the regulators have an auto shut off that needs to be reset. Try turning down the regulator dial until it closes and then opening it up slowly until it lights. That has worked for me a few times.



 
Reply With Quote
Old 03-02-2011, 10:03 PM   #3
MashTun-Kutcher
Recipes 
 
Jan 2011
Vancouver, Washington
Posts: 70

Ill give that a go

 
Reply With Quote
Old 03-03-2011, 03:26 PM   #4
mtbiker278
Recipes 
 
Nov 2010
Frederick, MD
Posts: 277
Liked 5 Times on 5 Posts


I've had mine not light right up a couple times. After a couple tried I'll just disconnect from the propane tank to relieve the pressure which should reset the flow restrictor (pressure sure it's spring loaded). If you're worried about the regulator they do sell replacements for relatively cheap (maybe consider exchanging it too?).
__________________
Prepare for Ludicrous Speed! Keezer Build

 
Reply With Quote
Old 03-08-2011, 05:32 AM   #5
MashTun-Kutcher
Recipes 
 
Jan 2011
Vancouver, Washington
Posts: 70

What is spring loaded?

 
Reply With Quote
Old 03-08-2011, 11:17 AM   #6
SwampassJ
Recipes 
 
Mar 2010
Coral Springs, FL
Posts: 2,161
Liked 37 Times on 34 Posts


Turn everything off and disconnect everything. Open the regulator and close it. Then attach it to the tank. Slowly turn the tank on. Slowly open the regulator and try lighting the burner while slowly opening it. If there is still a problem try a different tank if you have one or disconnect everything and give the rugulator a small tap.

 
Reply With Quote
Old 03-09-2011, 05:48 PM   #7
MashTun-Kutcher
Recipes 
 
Jan 2011
Vancouver, Washington
Posts: 70

Ok ill try it. I live on the west coast and the burner came from NY so i really dont want to send it back.

 
Reply With Quote
Old 03-09-2011, 06:01 PM   #8
Hethen57
Recipes 
 
Feb 2010
North Idaho
Posts: 132
Liked 3 Times on 2 Posts


There is no need to send it back. The majority of what you bought is in the stand and the burner, and there is really nothing mechanical inside that burner to fail. So your issue is either in your tank or your regulator.....probably your regulator. They have some type of auto shut off in there and I'm betting that yours is shut off. If you are at all mechanical, do some testing with air on that regulator to make sure you have flow and you should be fine. If not, and you are sure your tank is ok, then you may have to send your regulator back or buy a new one (about $15...which is alot cheaper than shipping the whole unit back).

 
Reply With Quote
Old 03-09-2011, 11:01 PM   #9
MashTun-Kutcher
Recipes 
 
Jan 2011
Vancouver, Washington
Posts: 70

Ok cool. The regulator looks like this http://www.turkey-fryers.com/7000_pr...stove_part.htm


The regulator i got looks trashed so im sure your right. What store sells regulators? id rather buy one where i live than order one online.

 
Reply With Quote
Old 03-09-2011, 11:17 PM   #10
SwampassJ
Recipes 
 
Mar 2010
Coral Springs, FL
Posts: 2,161
Liked 37 Times on 34 Posts


Quote:
Originally Posted by MashTun-Kutcher View Post
Ok cool. The regulator looks like this http://www.turkey-fryers.com/7000_pr...stove_part.htm


The regulator i got looks trashed so im sure your right. What store sells regulators? id rather buy one where i live than order one online.
Try Home Depot, Lowes, Walmart, or any grilling/bbq store.



 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trust issues blagoe Equipment/Sanitation 3 06-02-2010 05:04 AM
15g Megapot issues Croy9000 Equipment/Sanitation 9 09-20-2009 01:04 AM
MLT leakage issues Beernik Equipment/Sanitation 2 09-06-2009 03:00 AM
Infection issues :( fezzman Equipment/Sanitation 7 11-21-2008 06:17 PM
Burner Issues fredan Equipment/Sanitation 6 10-07-2008 11:54 AM


Forum Jump