Sorry to post again! Just a question about auto-siphon!

Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum

Help Support Homebrew Talk:

Scrow

Well-Known Member
Joined
Feb 16, 2009
Messages
103
Reaction score
0
I know I just posted the Apfelwine thread, but I had a semi-related but not entirely-related question. When I use my auto-siphon, I seem to have a LOT of aeration going on. If mine is like anyone elses, it is just a tube you stick in the wine/beer and pump to get the siphon action. Mine I have to continuosly pump to get the flow, and I get a TON of bubbles while siphoning. What am I doing wrong?
 

llazy_llama

Well-Known Member
Joined
Jan 20, 2009
Messages
2,832
Reaction score
92
Location
Rapid City, South Dakota
Is the container you're siphoning from higher than the container you're siphoning to?

If it's not that, your tubing might be lose. Either use smaller tubing or get a clamp.
 

kaptain_karma

Well-Known Member
Joined
Nov 9, 2005
Messages
304
Reaction score
1
Location
San Francisco
If your tubing isn't a perfect match for the autosiphon, you can get some air sucked in. I use a worm-gear type hose clamp to get a good seal. It also helps to give the autosiphon a couple pumps to push all the air out of the tube before you just let it run.
 
OP
S

Scrow

Well-Known Member
Joined
Feb 16, 2009
Messages
103
Reaction score
0
So if I get a clamp to make sure the seal is nice and tight, and I make sure I am siphoning into a lower container, I shouldn't need to pump more than a couple times, and it will do the rest?
 
Top