Quantcast

RRRRR! Must have a leak!

HomeBrewTalk.com - Beer, Wine, Mead, & Cider Brewing Discussion Community.

Help Support Homebrew Talk:

Chadwell

Active Member
Joined
Dec 27, 2008
Messages
36
Reaction score
0
Location
Boston, MA
Recently kegged a white belgian and pressurized it for a week and then stored it in my fridge. I pressurized at 10 PSI (perhaps low?). Regardless, I had some company over last night and decided it was time to have the beer. Tastes great but flat. I jacked it to 30 PSI overnight and this morning noticed my inside pressure (I have a dual-gauge) is just about at zero (it was at 600 or so, and outside of "the red" last night). I've gotta have a leak, right? I mean, a full tank gone already when it should last multiple kegs? The keg holds pressure (lid does not move at all and before I kegged I pumped a small amount of gas into it and let it sit for a week and the keg still had pressure when I pulled the release a week later. I would imagine a leak is in the gas hose (though brand new) or one of the connections within.

Any suggestions? I likely need to go fill the tank. Ugh! Annoying!
 

Loweface

Well-Known Member
Joined
Sep 10, 2007
Messages
1,037
Reaction score
11
Location
Limerick, Ireland
Are you sure the tank is empty?

I've heard people here say that a tank in the fridge can push the needle in the regulator into the red when the tank isn't. Perhaps this is the fault?

When you pressurized the keg did you leave the valves open so that more CO2 will be pulled from the tank as the liquid absorbs the gas?
 
OP
C

Chadwell

Active Member
Joined
Dec 27, 2008
Messages
36
Reaction score
0
Location
Boston, MA
Are you sure the tank is empty?

I've heard people here say that a tank in the fridge can push the needle in the regulator into the red when the tank isn't. Perhaps this is the fault?

When you pressurized the keg did you leave the valves open so that more CO2 will be pulled from the tank as the liquid absorbs the gas?
The tank is at the bottom of the red but it definitely still has gas in it. Not sure how much though. Time will tell. I just know that it dropped considerably in one night, which concerns me.

Hmm....well, I turned the knob on, had the gas line connected, and set the pressure with a flat head screwdriver on the front of the regulator. If there is another step I should have taken I may have missed it. I thought I had it all covered.
 
OP
C

Chadwell

Active Member
Joined
Dec 27, 2008
Messages
36
Reaction score
0
Location
Boston, MA
Problem solved! Yesterday I went out and refilled my tank. I disconnected everything and started over. SOMEONE (yes, it is me) forgot to put the white washer in the gas line on the regulator side. So, I lost much of the gas. Let that be a lesson to all!

Also, I picked up this tip on leak hunting from a friend of mine:

Easiest way to tell if you have a leak is to connect up everything but
don't connect the gas side disconnect onto the keg. Turn on you tank
and see that both gauges have pressure. Turn off the tank and let it
sit for a while. If either of the gauges drop, you have a leak.
 
Top