Hefeweizen stuck fermentation

HomeBrewTalk.com - Beer, Wine, Mead, & Cider Brewing Discussion Community.

Help Support Homebrew Talk:

Joined
Dec 25, 2007
Messages
19
Reaction score
0
Location
Washington, DC
Not my first hefeweizen, but my first from a 1.5L starter using a vial of yeast from my own yeast bank from WLP300 (thanks FlyGuy! https://www.homebrewtalk.com/showthread.php?t=35891). OG was 1.055 on 6/09. SG on 6/25 was 1.032. So i made another another 1.5L starter from another vial of my own yeast bank and pitched on 6/28. i had fermentation activity for 24 hours, but when i checked it tonight (6/30) the OG was still at 1.032. the temp is steady at 69F in a water tub.

if necessary i'll buy another WLP300 this weekend, create a 1.5L starter and pitch it.

but i'm curious if anyone can see why this fermentation is stuck?

thanks!

Keith in DC
 
OP
KeithLovesBeer
Joined
Dec 25, 2007
Messages
19
Reaction score
0
Location
Washington, DC
yes to AG batch, and the mash temp was on the money.

it's an experimental batch now, might as well find out what happens. i'll buy another liquid yeast this Sat., build up a good size starter and pitch it and report back to this thread about what happened in about a week.
 
OP
KeithLovesBeer
Joined
Dec 25, 2007
Messages
19
Reaction score
0
Location
Washington, DC
i thought perhaps shaking things up might generate yeast activity so i transferred the whole batch, including the yeast slurry, to a second carboy. a few days later mold spores appeared on the surface, the SG hadn't been reduced and it smelled like band aid stew. i dumped it and bounced back by brewing back to back batches of Ed Worts Ale.
 
Top