Dual tap kegerator only one gas line working

Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum

Help Support Homebrew Talk:

HMac

New Member
Joined
Jan 23, 2021
Messages
4
Reaction score
0
Hi all- long time lurker, first time poster. I recently got a new dual tap kegerator. It came with perlick lo-boy couplers. The regulator seems to be working fine at 10psi, but only one of the kegs is staying carbonated. I’ve switched the couplers and same thing. Air bubbles in the beer line and slow pour until nothing. No gas line leaks. Wondering if I have a faulty coupler?
 

day_trippr

"This Space For Rent"
Joined
May 31, 2011
Messages
38,198
Reaction score
21,246
Location
Stow, MA
Can you restate "I’ve switched the couplers and same thing." wrt whether the problem followed a coupler or stayed with one of the kegs...

Cheers!
 
OP
OP
H

HMac

New Member
Joined
Jan 23, 2021
Messages
4
Reaction score
0
The one works fine. I can switch it and the other ker pours fine. So, it seems to follow the coupler
 

day_trippr

"This Space For Rent"
Joined
May 31, 2011
Messages
38,198
Reaction score
21,246
Location
Stow, MA
btw, apologies for my obliviousness, and welcome to the forums at Homebrewtalk :mug:

Ok, so the dispensing problem (and presumably the carbonation problem) follows one coupler while the other seems to work fine, and you can't find anything leaking on the problematic coupler.

I don't use Sanke kegs and couplers, but I'm guessing there are at least a couple of critical O-rings involved in sealing the beer and gas feeds through the coupler to the keg. I'd give those a critical eye, perhaps there's something caught up or dinged on the gas side that's not actually allowing the head space to reach the gauge pressure...

Cheers!
 
Top