BrewPi Remix – What’s Old is New Again

Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum

Help Support Homebrew Talk - Beer, Wine, Mead, & Cider Brewing Discussion Forum:

athistle

Member
Joined
Aug 15, 2017
Messages
22
Reaction score
1
There's still something wrong - I thought I had the Tilt color in the header. I mean good it's not crashing, and yes it should be plotting the SG.

I wish I could explain how much this sucks living in an RV - at least when it comes to things like this.
No worries, the work you and @duncan.brown have put into this issue is simply amazing.
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
I'm having trouble with my temp sensors. They will after x amount of time start reading null. The amount of time is varied, it can read fine for days, but eventually it will go null. I have tried changing the USB wire from the Pi to the Aurdino, which "fixed" it for a little while but it eventually started reading null again. Googling this I came across a few threads on the Brewpi forumn where Elco says if they read null it is probably a wiring issue because that means the 5V wire is disconnected. I have redone the wiring which again "fixes" the issue for a short duration but I eventually get back to null.

I am running the Glycol firmware on the Aurdino and was initially running two Temperature probes. When the sensors go null if I unplug the 5V wire from the Aurdino or unplug the USB cable from the Pi it fixes it. One thing I notice is the temperature sensors read high initially and take ~5 minutes to come back down to normal temperature. Once they hit expected temperature they seem to be very stable in reading temperature. This led me to believe I had a bad sensor, so I unplugged one of them and again it fixed it long enough that I thought it was safe to brew but now is going null within hours.

Logs really don't show anything, but one thing I do notice is that I have 3 temperature sensors in Device Configuration. All three read the same temperature, but one has a different OneWire Address.

Any help would be appreciated, trying to keep this brew alive at least for the first three days.

Code:
cat stderr.txt
2022-05-21 19:26:49 [E] Starting BrewPi.
Terminating due to fatal serial error
2022-05-21 23:17:15 [E] Starting BrewPi.


cat stdout.txt
2022-05-21 23:17:15 [N] 0.8.1 (main) [c16adae]
2022-05-21 23:17:15 [N] Starting 'NE IPA.'
2022-05-21 23:17:15 [N] Opening serial port.
2022-05-21 23:17:17 [N] Waiting 10 seconds for board to restart.
2022-05-21 23:17:27 [N] Checking software version on controller.
2022-05-21 23:17:27 [N] Found BrewPi v0.2.13 build da7e14a9, running on an Arduino Uno with a Glycol shield on port /dev/glycol1.
2022-05-21 23:17:28 [N] New JSON received from controller.
2022-05-21 23:17:50 [N] New JSON received from controller.
2022-05-21 23:19:46 [N] New JSON received from controller.
2022-05-21 23:19:52 [N] New JSON received from controller.
2022-05-21 23:20:16 [N] New JSON received from controller.
2022-05-21 23:22:17 [N] New JSON received from controller.
2022-05-21 23:22:47 [N] New JSON received from controller.
2022-05-21 23:24:47 [N] New JSON received from controller.
2022-05-21 23:26:49 [N] New JSON received from controller.
2022-05-21 23:28:49 [N] New JSON received from controller.
2022-05-21 23:30:50 [N] New JSON received from controller.
2022-05-21 23:31:53 [N] Installed devices received: [{"i": 0, "t": 3, "c": 1, "b": 0, "f": 2, "h": 1, "d": 0, "p": 5, "v": 1, "x": 1}, {"i": 1, "t": 3, "c": 1, "b": 0, "f": 3, "h": 1, "d": 0, "p": 6, "v": 0, "x": 1}, {"i": 2, "t": 1, "c": 1, "b": 1, "f": 9, "h": 2, "d": 0, "p": 14, "v": 66.986, "a": "28EFB2D73C19013D", "j": 0.0}, {"i": 3, "t": 1, "c": 1, "b": 0, "f": 5, "h": 2, "d": 0, "p": 14, "v": 66.986, "a": "28EFB2D73C19013D", "j": 0.0}, {"i": 4, "t": 1, "c": 1, "b": 1, "f": 9, "h": 2, "d": 0, "p": 14, "v": 66.986, "a": "28FF5DD93C1901C6", "j": 0.0}]
2022-05-21 23:31:53 [N] Available devices received: [{"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 2, "x": 1}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 10, "x": 1}]
2022-05-21 23:32:51 [N] New JSON received from controller.

Screenshot from 2022-05-21 23-36-51.png
 
OP
OP
LBussy

LBussy

A Cunning Linguist
HBT Supporter
Joined
Jan 19, 2013
Messages
3,886
Reaction score
1,679
Location
Rural Kansas
@thestraw0039 - what you describe is generally attributable to a good, clean power source for the sensors. Secondarily we have seen where a stronger pull-down helps, especially with longer lead lengths. The two things I would try:

Get a good 9v power supply and use that to power the Arduino.

https://support.arduino.cc said:
The AC adapters are commonly available in retail stores for use with consumer products are often suitable, but make sure that it has the proper connector for plugging into the power socket on your Arduino board: 5.5mm diameter cylindrical plug with 2.1mm pin hole, and that provides Positive voltage on the inside pin hole and Negative (or common/ground) voltage on the outside cylindrical sleeve of the connector plug.

Something like this one from Amazon should work well:

I recommend that one over a few that are a couple of dollars less because it is rated for 2A. What that means in Chinese specifications is maybe 1A which is more than enough for you.

Secondarily, if that doesn't work, try a stronger pull-up resistor. If you are using a 4k7, use a 2k2. If you don't have one handy you can use a second 4k7 in parallel to get close to a 2k2 value (2350k.)
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
Thanks LBussy, I currently don't have any power for the Aurdino, just what it pulls off the USB from the Pi. I ordered what you recommended and it should be here tomorrow so I will report back. I did add longer wires for my temp sensors so it makes sense it is a power issue.

I also don't believe I have a 2k2 resistor on hand, but have plenty of 4k7 (if that is what I put in originally). I had to order about a hundred for the one I needed so I'll add a second and see if it helps.
 

day_trippr

Structural Duct Tape Sales Engineer
Joined
May 31, 2011
Messages
38,656
Reaction score
21,852
Location
Stow, MA
one thing I do notice is that I have 3 temperature sensors in Device Configuration. All three read the same temperature, but one has a different OneWire Address.

Given you only have two actual sensors, that ain't right, and you need to fix it...

Cheers!
 

duncan.brown

Supporting Member
HBT Supporter
Joined
Apr 8, 2020
Messages
866
Reaction score
812
Location
Syracuse
Secondarily, if that doesn't work, try a stronger pull-up resistor. If you are using a 4k7, use a 2k2. If you don't have one handy you can use a second 4k7 in parallel to get close to a 2k2 value (2350k.)

Ah, cheers @LBussy a lower resistance pull-up has fixed the intermittent problems I have with the temp probe on my mash tun and HTL!
 

duncan.brown

Supporting Member
HBT Supporter
Joined
Apr 8, 2020
Messages
866
Reaction score
812
Location
Syracuse
Back in January, I decided to put Brewpi Remix through its paces and programed in a fermentation profile I got from Bierstadt Lagerhaus in Denver, CO. A full 40 days in the fermenter, followed by three months of lagering. Damn this beer is good! Crystal clear and drinkable by the liter! Cheers!

Screen Shot 2022-05-22 at 3.07.39 PM.png


IMG_2046.jpeg
 

day_trippr

Structural Duct Tape Sales Engineer
Joined
May 31, 2011
Messages
38,656
Reaction score
21,852
Location
Stow, MA
Then there's something amiss. I'm betting the eeprom needs to be wiped and devices configured from fresh...

Cheers!
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
Then there's something amiss. I'm betting the eeprom needs to be wiped and devices configured from fresh...

Cheers!
That's been done, now I just have the one sensor, I also added the second resistor. The power cord for the Aurdino should be here tomorrow.

It's been a fun day trying to keep this afloat.
 

Attachments

  • Screenshot from 2022-05-22 22-26-33.png
    Screenshot from 2022-05-22 22-26-33.png
    157.8 KB · Views: 0

day_trippr

Structural Duct Tape Sales Engineer
Joined
May 31, 2011
Messages
38,656
Reaction score
21,852
Location
Stow, MA
One thing to note when running BrewPi with a single sensor is you can only run in Fridge Constant mode.
Both Beer Constant and Beer Profile modes require a minimum of two sensors to operate correctly...

Cheers!
 

duncan.brown

Supporting Member
HBT Supporter
Joined
Apr 8, 2020
Messages
866
Reaction score
812
Location
Syracuse
I am running the Glycol firmware on the Aurdino and was initially running two Temperature probes.

@day_trippr I think @thestraw0039 is running the glycol version of the code which works fine with one sensor. I never got round to fixing the GUI for glycol, so both the beer and fridge temperatures display the same value. Control is done on the beer temperature.
 

day_trippr

Structural Duct Tape Sales Engineer
Joined
May 31, 2011
Messages
38,656
Reaction score
21,852
Location
Stow, MA
Did not know that, thanks. What was the reason for not using "Fridge Constant"?

Cheers!
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
Yeah I'm running the glycol build. Update so far reflashing the Aurdino and adding the extra resistor seems to be working. My wife sent me a screen shot and it is still reading temperature as of about 4 this afternoon. My power supply got here and I'll put it in tonight. Thanks for the help everyone.

@duncan.brown are you still running temperature idle range top to 1F? It was initially set to 1.83 and I thought I broke something when beer temp was rising past my set temperature and brewpi wasn't putting the cooling on. I changed it to 1 but was considering going to 0.5
 

duncan.brown

Supporting Member
HBT Supporter
Joined
Apr 8, 2020
Messages
866
Reaction score
812
Location
Syracuse
@duncan.brown are you still running temperature idle range top to 1F? It was initially set to 1.83 and I thought I broke something when beer temp was rising past my set temperature and brewpi wasn't putting the cooling on. I changed it to 1 but was considering going to 0.5

My glycol is set to 28F to keep my long-draw loop cold, which drops the temp in my tanks like a stone when the pump comes on. This generally gets me an overshoot, even with some tweaking of the parameters. The following work well for me:

Temperature idle range top: 0.998
Temperature idle range bottom: -1.502
Heating target upper bound: 0.541
Heating target lower bound: -0.359
Cooling target upper bound: 0.359
Cooling target lower bound: -0.541
Maximum time in seconds for heating overshoot estimator: 600
Maximum time in seconds for cooling overshoot estimator: 1200

Kp, Ki, and Kd are all set to 0 to disable the PID. I had some discussion with Lee a while ago about this and came to the decision that it’s not worth tuning the PID loop when the glycol is on an on/off pump.

Again, see post above. I get some cooling overshoot, but it still makes a damn good beer!
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
So not sure what happened last night, but got home and hadn't had any issues all day. I got the power supply so I plugged that into the Ardiuno and everything went smoothly until around 10. I looked at the website and the temperature went null. I went out and unplugged the USB from the Pi and it didn't turn back on. I then figured out I had the power supply attached so I opened it up and pulled out the 5V pin, replugged and the temperature came back on as expected.

Went to bed and everything was fine. I woke up this morning to the glycol chiller running all night yet the temperature reading 67 degrees. So went downstairs, decided I was switching the probe out, which I did. When I went to the website again Devices wouldn't load, restarted the Pi and then the BrewPi service wouldn't start. After digging on why the Aurdino couldn't be found. Unplugged it from the Pi and the power source and plugged everything back in and the Pi found the Aurdino, set up the new sensor and it appears like we are running again. Is there a chance my Ardiuno is going and I should buy a new one? At this point I'm just going to let this run and see what happens.

If anyone wants to copy my beer profile go for it, I probably should take this moment to dry hop since I have now cold crashed.

Edit: Sensor is null again, bought a new Arduino see if that fixes it
 

Attachments

  • Screenshot from 2022-05-24 08-35-05.png
    Screenshot from 2022-05-24 08-35-05.png
    154.7 KB · Views: 0
Last edited:
OP
OP
LBussy

LBussy

A Cunning Linguist
HBT Supporter
Joined
Jan 19, 2013
Messages
3,886
Reaction score
1,679
Location
Rural Kansas
To figure it out we'd need to see the /home/brewpi/logs/stdout.txt and /home/brewpi/logs/stderr.txt. I've got ideas but I'd prefer not to guess and step through it carefully.
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
Bash:
[email protected]:~/glycol1/logs $ cat stderr.txt
2022-05-21 19:26:49 [E] Starting BrewPi.
Terminating due to fatal serial error
2022-05-21 23:17:15 [E] Starting BrewPi.
Terminating due to fatal serial error
2022-05-22 12:29:57 [E] Starting BrewPi.
Terminating due to fatal serial error
2022-05-22 16:23:48 [E] Starting BrewPi.
Terminating due to fatal serial error
2022-05-22 19:59:15 [E] Starting BrewPi.
2022-05-22 21:24:33 [E] Starting BrewPi.
Terminating due to fatal serial error
2022-05-23 22:19:47 [E] Starting BrewPi.
2022-05-24 07:54:24 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:54:36 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:54:48 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:55:00 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:55:12 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:55:39 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:55:51 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:56:03 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:56:15 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:56:27 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:56:39 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:56:51 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:57:03 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:57:15 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:57:27 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:57:39 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:57:51 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:58:03 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:58:15 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:58:27 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:58:39 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:58:51 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:59:03 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:59:15 [E] Starting BrewPi.
Error(s) while opening serial port:  [Errno 2] could not open port /dev/glycol1: [Errno 2] No such file or directory: '/dev/glycol1'

2022-05-24 07:59:27 [E] Starting BrewPi.
2022-05-24 07:59:45 [E] Caught a socket error.
2022-05-24 07:59:45 [E] Error info:
2022-05-24 07:59:45 [E]     Error: (32): 'Broken pipe'
2022-05-24 07:59:45 [E]     Type: <class 'BrokenPipeError'>
2022-05-24 07:59:45 [E]     Filename: brewpi.py
2022-05-24 07:59:45 [E]     LineNo: 1474
2022-05-24 07:59:47 [E] Starting BrewPi.
Bash:
[email protected]:~/glycol1/logs $ cat stdout.txt
2022-05-24 07:59:47 [N] 0.8.1 (main) [c16adae]
2022-05-24 07:59:47 [N] Starting 'NE IPA.'
2022-05-24 07:59:47 [N] Opening serial port.
2022-05-24 07:59:47 [N] Waiting 10 seconds for board to restart.
2022-05-24 07:59:57 [N] Checking software version on controller.
2022-05-24 07:59:57 [N] Found BrewPi v0.2.13 build da7e14a9, running on an Arduino Uno with a Glycol shield on port /dev/glycol1.
2022-05-24 07:59:57 [N] New JSON received from controller.
2022-05-24 08:00:17 [N] Installed devices received: [{"i": 0, "t": 1, "c": 1, "b": 1, "f": 9, "h": 2, "d": 0, "p": 14, "v": null, "a": "28FF5DD93C1901C6", "j": 0.0}, {"i": 1, "t": 3, "c": 1, "b": 0, "f": 2, "h": 1, "d": 0, "p": 5, "v": 0, "x": 1}, {"i": 2, "t": 3, "c": 1, "b": 0, "f": 3, "h": 1, "d": 0, "p": 6, "v": 0, "x": 1}]
2022-05-24 08:00:17 [N] Available devices received: [{"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 2, "d": 0, "p": 14, "v": 185.0, "a": "28726AEC3C19017A", "j": 0.0}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 2, "x": 1}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 10, "x": 1}]
2022-05-24 08:00:24 [N] Installed devices received: [{"i": 0, "t": 1, "c": 1, "b": 1, "f": 9, "h": 2, "d": 0, "p": 14, "v": null, "a": "28FF5DD93C1901C6", "j": 0.0}, {"i": 1, "t": 3, "c": 1, "b": 0, "f": 2, "h": 1, "d": 0, "p": 5, "v": 0, "x": 1}, {"i": 2, "t": 3, "c": 1, "b": 0, "f": 3, "h": 1, "d": 0, "p": 6, "v": 0, "x": 1}]
2022-05-24 08:00:24 [N] Available devices received: [{"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 2, "d": 0, "p": 14, "v": 44.824, "a": "28726AEC3C19017A", "j": 0.0}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 2, "x": 1}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 10, "x": 1}]
2022-05-24 08:00:26 [N] Installed devices received: [{"i": 0, "t": 1, "c": 1, "b": 1, "f": 9, "h": 2, "d": 0, "p": 14, "v": null, "a": "28FF5DD93C1901C6", "j": 0.0}, {"i": 1, "t": 3, "c": 1, "b": 0, "f": 2, "h": 1, "d": 0, "p": 5, "v": 0, "x": 1}, {"i": 2, "t": 3, "c": 1, "b": 0, "f": 3, "h": 1, "d": 0, "p": 6, "v": 0, "x": 1}]
2022-05-24 08:00:26 [N] Available devices received: [{"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 2, "d": 0, "p": 14, "v": 44.824, "a": "28726AEC3C19017A", "j": 0.0}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 2, "x": 1}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 10, "x": 1}]
2022-05-24 08:00:59 [N] Device updated to: {"i":0,"t":1,"c":1,"b":1,"f":9,"h":2,"d":0,"p":14,"a":"28726AEC3C19017A","j": 0.000}
2022-05-24 08:00:59 [N] Installed devices received: [{"i": 0, "t": 1, "c": 1, "b": 1, "f": 9, "h": 2, "d": 0, "p": 14, "v": 44.824, "a": "28726AEC3C19017A", "j": 0.0}, {"i": 1, "t": 3, "c": 1, "b": 0, "f": 2, "h": 1, "d": 0, "p": 5, "v": 0, "x": 1}, {"i": 2, "t": 3, "c": 1, "b": 0, "f": 3, "h": 1, "d": 0, "p": 6, "v": 0, "x": 1}]
2022-05-24 08:00:59 [N] Available devices received: [{"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 2, "x": 1}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 10, "x": 1}]
2022-05-24 08:00:59 [N] New JSON received from controller.
2022-05-24 08:01:08 [N] Installed devices received: [{"i": 0, "t": 1, "c": 1, "b": 1, "f": 9, "h": 2, "d": 0, "p": 14, "v": 44.824, "a": "28726AEC3C19017A", "j": 0.0}, {"i": 1, "t": 3, "c": 1, "b": 0, "f": 2, "h": 1, "d": 0, "p": 5, "v": 1, "x": 1}, {"i": 2, "t": 3, "c": 1, "b": 0, "f": 3, "h": 1, "d": 0, "p": 6, "v": 0, "x": 1}]
2022-05-24 08:01:08 [N] Available devices received: [{"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 2, "x": 1}, {"i": -1, "t": 0, "c": 1, "b": 0, "f": 0, "h": 1, "d": 0, "p": 10, "x": 1}]
2022-05-24 08:03:00 [N] New JSON received from controller.
2022-05-24 08:05:01 [N] New JSON received from controller.
2022-05-24 08:07:01 [N] New JSON received from controller.
2022-05-24 08:09:02 [N] New JSON received from controller.
2022-05-24 08:11:02 [N] New JSON received from controller.
2022-05-24 08:13:03 [N] New JSON received from controller.
2022-05-24 08:15:03 [N] New JSON received from controller.
2022-05-24 08:17:05 [N] New JSON received from controller.
2022-05-24 08:19:05 [N] New JSON received from controller.
2022-05-24 08:21:06 [N] New JSON received from controller.
2022-05-24 08:23:06 [N] New JSON received from controller.
2022-05-24 08:25:07 [N] New JSON received from controller.
2022-05-24 08:27:08 [N] New JSON received from controller.
2022-05-24 08:29:08 [N] New JSON received from controller.
2022-05-24 08:31:09 [N] New JSON received from controller.
2022-05-24 08:33:10 [N] New JSON received from controller.
2022-05-24 08:35:11 [N] New JSON received from controller.
2022-05-24 08:37:12 [N] New JSON received from controller.
2022-05-24 08:39:13 [N] New JSON received from controller.
2022-05-24 08:41:13 [N] New JSON received from controller.
2022-05-24 08:43:14 [N] New JSON received from controller.
2022-05-24 08:45:15 [N] New JSON received from controller.
2022-05-24 08:47:16 [N] New JSON received from controller.
2022-05-24 08:49:16 [N] New JSON received from controller.
2022-05-24 08:51:17 [N] New JSON received from controller.
2022-05-24 08:53:18 [N] New JSON received from controller.
2022-05-24 08:55:19 [N] New JSON received from controller.
2022-05-24 08:57:20 [N] New JSON received from controller.
2022-05-24 08:59:21 [N] New JSON received from controller.
2022-05-24 09:01:22 [N] New JSON received from controller.
2022-05-24 09:03:23 [N] New JSON received from controller.
2022-05-24 09:05:23 [N] New JSON received from controller.
2022-05-24 09:07:24 [N] New JSON received from controller.
2022-05-24 09:09:24 [N] New JSON received from controller.
2022-05-24 09:11:25 [N] New JSON received from controller.
2022-05-24 09:13:25 [N] New JSON received from controller.
2022-05-24 09:15:26 [N] New JSON received from controller.
2022-05-24 09:17:27 [N] New JSON received from controller.
2022-05-24 09:19:28 [N] New JSON received from controller.
2022-05-24 09:19:31 [N] New JSON received from controller.
2022-05-24 09:21:32 [N] New JSON received from controller.
2022-05-24 09:23:32 [N] New JSON received from controller.
2022-05-24 09:25:34 [N] New JSON received from controller.
2022-05-24 09:27:34 [N] New JSON received from controller.
2022-05-24 09:29:35 [N] New JSON received from controller.
2022-05-24 09:31:36 [N] New JSON received from controller.
2022-05-24 09:33:37 [N] New JSON received from controller.
2022-05-24 09:35:38 [N] New JSON received from controller.
2022-05-24 09:37:39 [N] New JSON received from controller.
2022-05-24 09:39:39 [N] New JSON received from controller.
2022-05-24 09:41:40 [N] New JSON received from controller.
2022-05-24 09:43:40 [N] New JSON received from controller.
2022-05-24 09:45:41 [N] New JSON received from controller.
2022-05-24 09:47:41 [N] New JSON received from controller.
2022-05-24 09:49:42 [N] New JSON received from controller.
2022-05-24 09:51:43 [N] New JSON received from controller.
2022-05-24 09:53:44 [N] New JSON received from controller.
2022-05-24 09:55:44 [N] New JSON received from controller.
2022-05-24 09:57:46 [N] New JSON received from controller.
2022-05-24 09:59:46 [N] New JSON received from controller.
2022-05-24 10:01:47 [N] New JSON received from controller.
2022-05-24 10:03:48 [N] New JSON received from controller.
2022-05-24 10:05:49 [N] New JSON received from controller.
2022-05-24 10:07:50 [N] New JSON received from controller.
2022-05-24 10:09:51 [N] New JSON received from controller.
2022-05-24 10:11:52 [N] New JSON received from controller.
2022-05-24 10:13:53 [N] New JSON received from controller.
2022-05-24 10:15:53 [N] New JSON received from controller.
2022-05-24 10:17:54 [N] New JSON received from controller.
2022-05-24 10:19:55 [N] New JSON received from controller.
2022-05-24 10:21:56 [N] New JSON received from controller.
2022-05-24 10:23:57 [N] New JSON received from controller.
2022-05-24 10:25:58 [N] New JSON received from controller.
2022-05-24 10:27:59 [N] New JSON received from controller.
2022-05-24 10:30:00 [N] New JSON received from controller.
2022-05-24 10:32:00 [N] New JSON received from controller.
2022-05-24 10:34:01 [N] New JSON received from controller.
2022-05-24 10:36:02 [N] New JSON received from controller.
2022-05-24 10:38:03 [N] New JSON received from controller.
2022-05-24 10:40:04 [N] New JSON received from controller.
2022-05-24 10:42:05 [N] New JSON received from controller.
2022-05-24 10:44:06 [N] New JSON received from controller.
2022-05-24 10:46:06 [N] New JSON received from controller.
2022-05-24 10:48:07 [N] New JSON received from controller.
2022-05-24 10:50:08 [N] New JSON received from controller.
2022-05-24 10:52:09 [N] New JSON received from controller.
2022-05-24 10:54:10 [N] New JSON received from controller.
2022-05-24 10:56:11 [N] New JSON received from controller.
2022-05-24 10:58:12 [N] New JSON received from controller.
2022-05-24 11:00:13 [N] New JSON received from controller.
2022-05-24 11:02:13 [N] New JSON received from controller.
2022-05-24 11:04:14 [N] New JSON received from controller.
2022-05-24 11:06:15 [N] New JSON received from controller.

I assume you want JSON logging on, I'm trying to find how to do that, I remember you mentioned it to someone else, I'll turn it on and post that when it runs for a little bit.
 
OP
OP
LBussy

LBussy

A Cunning Linguist
HBT Supporter
Joined
Jan 19, 2013
Messages
3,886
Reaction score
1,679
Location
Rural Kansas
No, actually that's fine. It tells us that the Pi to Arduino communication is what was impacted. The firmware is pretty well baked with few changes, so I am curious about the loss of comms. You said you rebooted the Pi, right? And then the comms errors persisted?

It sure seems like the Arduino locked up, but it could also be a questionable USB cable. Try a different port on the Pi, try a different USB cable, and see if that helps.
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
Quick pull of the code it was complaining about above, assume it just couldn't find the Arduino.

Bash:
[email protected]:~/glycol1 $ sed -n 1470,1480p brewpi.py
                                status[statusIndex].update({statusType: statusValue})
                                statusIndex = statusIndex + 1
                    # End: iSpindel Items

                    phpConn.send(json.dumps(status).encode(encoding="utf-8"))
                else:  # Invalid message received
                    logMessage(
                        "ERROR. Received invalid message on socket: " + message)

                if (time.time() - prevTimeOut) < serialCheckInterval:
                    continue

Log with JSON logging on:

Bash:
[email protected]:~/glycol1/logs $ cat stdout.txt
2022-05-24 11:14:28 [N] 0.8.1 (main) [c16adae]
2022-05-24 11:14:28 [N] Starting 'NE IPA.'
2022-05-24 11:14:28 [N] Opening serial port.
2022-05-24 11:14:28 [N] Waiting 10 seconds for board to restart.
2022-05-24 11:14:38 [N] Checking software version on controller.
2022-05-24 11:14:38 [N] Found BrewPi v0.2.13 build da7e14a9, running on an Arduino Uno with a Glycol shield on port /dev/glycol1.
2022-05-24 11:14:39 [N] Update: {"BeerTemp": null, "FridgeTemp": null, "BeerAnn": null, "FridgeAnn": null, "RoomTemp": null, "State": 0, "BeerSet": 68.1, "FridgeSet": 68.1}
2022-05-24 11:16:40 [N] Update: {"BeerTemp": null, "FridgeTemp": null, "BeerAnn": null, "FridgeAnn": null, "RoomTemp": null, "State": 0, "BeerSet": 68.14, "FridgeSet": 68.14}
2022-05-24 11:18:41 [N] Update: {"BeerTemp": null, "FridgeTemp": null, "BeerAnn": null, "FridgeAnn": null, "RoomTemp": null, "State": 0, "BeerSet": 68.14, "FridgeSet": 68.14}
2022-05-24 11:20:42 [N] Update: {"BeerTemp": null, "FridgeTemp": null, "BeerAnn": null, "FridgeAnn": null, "RoomTemp": null, "State": 0, "BeerSet": 68.14, "FridgeSet": 68.14}
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
No, actually that's fine. It tells us that the Pi to Arduino communication is what was impacted. The firmware is pretty well baked with few changes, so I am curious about the loss of comms. You said you rebooted the Pi, right? And then the comms errors persisted?

It sure seems like the Arduino locked up, but it could also be a questionable USB cable. Try a different port on the Pi, try a different USB cable, and see if that helps.
After the reboot it still wouldn't talk to the Arduino, I had to pull the power to the Arduino to get the two talking again. After that connected fine but the temp sensor eventually went null again.

Edit: First thing I did was replace the USB cable, but I'll try a different port.
 

thestraw0039

Active Member
Joined
Feb 19, 2012
Messages
40
Reaction score
5
Location
Willow Grove
Update:

New Arduino didn't help, lower resistor didn't help. Finally decided to go back to my shorter sensors that worked with the original Brewpi. Not sure if the longer sensors I got were just junk, appears that way, but BrewPi Remix has been perfect since switching back. :mug: to anyone who helped, hope this helps someone else in the future.
 

Attachments

  • Screenshot from 2022-05-30 10-20-28.png
    Screenshot from 2022-05-30 10-20-28.png
    151.4 KB · Views: 0

balrog

Supporting Member
HBT Supporter
Joined
Nov 26, 2013
Messages
5,373
Reaction score
7,093
go back to my shorter sensors that worked with the original Brewpi. Not sure if the longer sensors I got were just junk, appears that way

I am coming to the same conclusion, but with sainsmart arduino "broken pipe" on laptop solution not raspberry pi. I think I have to get another arduino
 

duncan.brown

Supporting Member
HBT Supporter
Joined
Apr 8, 2020
Messages
866
Reaction score
812
Location
Syracuse
With the lines above commented out, it doesn’t crash the script, but you get NAN for the temperatures from the tilt

I did a bit of digging and the code wasn't generating NANs. There's a default that sets the tilt data to N/A and I was mis-reading N/AN/AN/A as NAN for some reason (probably years of writing dodgy numerical analysis code).

The slowness on the web page was just oversampling of the data. I reduced the sampling interval to 30 mins and my last brew has been fine. The patches also work if the tilt disappears and comes back.
 

wootz001

Member
Joined
Nov 19, 2010
Messages
12
Reaction score
1
Location
Long Beach
Getting back into DIY brewing gizmos after a little bit of a break. What's got me most excited is controlling my glycol system and Brew Bubbles set up and integrated with logging.

I noticed that a couple old boards that I had in my box of doodads will work with Fermentrack, but not With BrewPi Remix:

1) Adafruit "Metro" (Arduino UNO clone ATMega328P)
2) Adafruit "HUZZAH Feather" (ESP8266)

Both are flashed to the latest relevant firmware, but BrewPiRemix is reporting the following:
... Starting BrewPi. Error(s) while opening serial port: Could not find compatible serial device.

Of course, the Wemos D1 Mini clone I have seems to work just fine.

Not a big deal, just wondering if there is a known difference between Fermentrack and BrewpiRemix for these boards? Do I just need to shop and find a different Arduino UNO compatible board (any suggestions)? I can also bug @Thorrak about finishing his Brew Bubbles integration with Fermentrack, and solve my problem that way too! ;)

Also want to extend my thanks to all who have contributed to and supported these projects. I'm getting back into it after a few years away, and WOW things have come a long way! Thanks!
 
OP
OP
LBussy

LBussy

A Cunning Linguist
HBT Supporter
Joined
Jan 19, 2013
Messages
3,886
Reaction score
1,679
Location
Rural Kansas
There’s probably no absolute reason why that can’t work, I’d just need to look at the (I forget which file) and add a board definition for it. I might need to get more info from you.

That said, I’m hoping @Thorrak will release his ESP ….. ah you almost made me say it! Cooler things coming, which I will support in BPR.
 

Thorrak

Supporting Member
HBT Supporter
Joined
Feb 7, 2016
Messages
3,314
Reaction score
2,152
Location
New York, NY
There’s probably no absolute reason why that can’t work, I’d just need to look at the (I forget which file) and add a board definition for it. I might need to get more info from you.

That said, I’m hoping @Thorrak will release his ESP ….. ah you almost made me say it! Cooler things coming, which I will support in BPR.

Hmmmmm….

If you’re referring to the solder-free BrewPi-ESP32 with native Tilt support, support for Kasa WiFi switches, and Inkbird Bluetooth temperature sensors, I’ve already announced that one over here.

Of course, if you’re thinking of the ESP32-S2 port, which brings a (more) modern platform than the D1 mini along with Kasa switch support, then that was announced this past Monday.

Of course I did send you that thing… if I can get the case ready for it, it should be available soon.
 

scubahiker

Member
Joined
Oct 21, 2015
Messages
22
Reaction score
2
Hello all, I just ran the update and now up to the current version. When I tried to update my controller it failed, unable to find the updateFirmware.py script.

Did I miss something? I searched for this file and its not in the brewpi folder.
 

scubahiker

Member
Joined
Oct 21, 2015
Messages
22
Reaction score
2
Thanks, I do not see a doFiware in my utils folder. I do have a doFlash? Would that be it?

When I run doUpdate, thats whats calling the old updateFirmware.
 
OP
OP
LBussy

LBussy

A Cunning Linguist
HBT Supporter
Joined
Jan 19, 2013
Messages
3,886
Reaction score
1,679
Location
Rural Kansas
Thanks, I do not see a doFiware in my utils folder. I do have a doFlash? Would that be it?

When I run doUpdate, thats whats calling the old updateFirmware.
Yes, that's it. doFlash.sh further calls updateFirmware.py. Are you saying that you receive an error running doFlash.sh? Is updateFirmware.py in the /home/brewpi folder? If so, are you running the script as root or as the pi user? You should be able to run it as pi from your home folder.

ETA: There are VERY minimal changes in the BrewPi firmware from the original Elco version. It's not worth the effort unless you just really want to see it all working.
 

Latest posts

Top