Home Brew Forums > Home Brewing Beer > Beginners Beer Brewing Forum > What did I do wrong?
Reply
 
Thread Tools
Old 12-30-2008, 07:35 PM   #1
isp845
Feedback Score: 0 reviews
Recipes 
 
Join Date: Dec 2008
Posts: 3
Default What did I do wrong?

I brewed my first kit on 12/18/08. It was an extract kit from NB it was the cream ale. I followed the instructions.... and took a hydrometer reading at 60 deg. It read 1.063. I took a reading just now at about 60 deg +/- a few degrees. It read 1.015. The kit stated an og of 1.040.

What did I do wrong? Do I need to let it sit a while longer? It smelled good and I drank the sample and it was ok (flat). Any expertise would be appreciated... Thanks


isp845 is offline
 
Reply With Quote
Old 12-30-2008, 07:39 PM   #2
GreenwoodRover
me-no-r-no Nice Guy
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
 
GreenwoodRover's Avatar
Recipes 
 
Join Date: Mar 2008
Location: Chicago, IL
Posts: 1,060
Liked 10 Times on 9 Posts

Default

First - it's no big deal.
You can never be that far off your OG on an extract kit. My guess is that the top-up water was not well mixed when you took yout initial OG reading.
Take another gravity reading tomorrow or the next day, if it's still 1.015, rack/bottle it.

Enjoy.


__________________
Quote:
Originally Posted by david_42 View Post
only the $500,000 strippers can handle the load.
<Insert list of brews planned, fermenting, or being consumed here>
GreenwoodRover is offline
 
Reply With Quote
Old 12-30-2008, 08:27 PM   #3
FxdGrMind
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2008
Location: PNW
Posts: 562
Liked 1 Times on 1 Posts

Default

You drank the sample and it was OK...

I'd call that a Success!!!

You are far ahead of me and I'm green with envy!
FxdGrMind is offline
 
Reply With Quote
Old 12-30-2008, 09:00 PM   #4
Couldbebrewing
Feedback Score: 0 reviews
Recipes 
 
Join Date: Dec 2008
Location: Columbus GA
Posts: 24
Default

Quote:
Originally Posted by FxdGrMind View Post
You drank the sample and it was OK...

I'd call that a Success!!!

You are far ahead of me and I'm green with envy!
indeed. i am roughly 3 weeks out of trying my first batch and i hope i can say that it is ok.
Couldbebrewing is offline
 
Reply With Quote
Reply


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Always the wrong place wrong time OHIOSTEVE Wine Making Forum 7 10-04-2009 07:07 PM
I did it wrong didn't I? bernerbrau All Grain & Partial Mash Brewing 18 07-12-2009 09:54 AM
what am I doing wrong? Oakwood Extract Brewing 21 07-07-2009 12:44 PM
Where did I go wrong? BeerRenter General Beer Discussion 3 12-11-2007 02:48 PM
What went wrong? mot Extract Brewing 12 05-09-2007 08:18 PM


Forum Jump

Newest Threads

LATEST SPONSOR DEALS