No beer from King Keg - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > Beginners Beer Brewing Forum > No beer from King Keg

Thread Tools
Old 02-06-2006, 02:04 PM   #1
Feb 2006
Posts: 8

Hi everyone,
I hope someone out there can help.
I brewed a beer in a fermenter until gravity was stable at 1006. (7days) A brew belt was attached to a King Keg top tap and the beer was transfered to it. I took the brew belt off after two days and left the beer in a cool place. When I tried to sample the beer a few days later nothing came from the tap so a gave it a blast of co2 but still nothing so I gave it a further 2 1sec blasts but still no beer from the tap.
What am I doing/or what's wrong?

Reply With Quote
Old 02-06-2006, 02:30 PM   #2
El Pistolero
El Pistolero's Avatar
May 2005
Houston, Baja Oklahoma
Posts: 3,585
Liked 15 Times on 15 Posts

Don't you have to prime a king keg? Assuming you did prime it, isn't it still going to take 2-3 weeks to carbonate?
[/I] Up Next - Hobgoblin
After That - Czech Pilsner
Primary - Humboldt Hop Rod (4/24)
Primary - NOT Wheat AG SNCA (5/5)
Secondary -
Conditioning - SNCA Clone (3/3),

Reply With Quote
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
My new favorite beer -Greene King IPA- Desert_Sky Commercial Brew Discussion 3 07-09-2010 10:11 PM
I'm F**king Matt Damon.....I'm F**king Ben Affleck talleymonster Drunken Ramblings and Mindless Mumbling 20 09-30-2008 03:21 PM
No beer from Pressurised King Keg kevinrhaart Bottling/Kegging 2 02-06-2006 06:47 PM

Forum Jump