Yeast Starter - DME not mixing in well enough? - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > Beginners Beer Brewing Forum > Yeast Starter - DME not mixing in well enough?

Reply
 
Thread Tools
Old 01-04-2008, 08:05 PM   #1
barnes
Recipes 
 
Nov 2007
Schaumburg, IL
Posts: 47


I'm making my first yeast starter right now. Mixed 2 oz DME with 500ml water, heated it up in a pot for 5 minutes and stirred, then added to Erlenmeyer flask, boiled for 15-20 minutes. It's now cooling down and there is a noticeable amount of DME on the bottom of the flask, as if it didn't mix well. Is this just "cold break" or something?

I tried looking this up, but couldn't find any information on it. I'm asking because I can easily just use the XL smack pack by itself tomorrow if this sounds strange.

 
Reply With Quote
Old 01-04-2008, 08:08 PM   #2
Ryan_PA
 
Ryan_PA's Avatar
Recipes 
 
Aug 2006
Horsham, PA, Pennsylvania
Posts: 1,881
Liked 12 Times on 8 Posts


Most likely a mix of trub materials and cold break. I usually get about a tranlucent coating when doing a 2L starter with DME. You should be more than fine.

 
Reply With Quote
Old 01-04-2008, 08:10 PM   #3
barnes
Recipes 
 
Nov 2007
Schaumburg, IL
Posts: 47

Thanks for the reply.... here I go, first yeast starter!

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mixing ale yeast and lager yeast- will it work??? kaj030201 General Techniques 8 11-11-2008 05:28 PM
Mixing yeast strains? BeerAg General Techniques 5 08-28-2007 08:52 PM
Mixing yeast wstein Recipes/Ingredients 1 10-02-2006 05:09 PM
Not mixing in yeast? mrkeeg General Techniques 4 04-04-2005 08:41 PM


Forum Jump