PID Thermocouple question - Home Brew Forums
Register Now For Free!

Home Brew Forums > Home Brewing Beer > Automated Brewing Forum > PID Thermocouple question

Reply
 
Thread Tools
Old 04-27-2013, 02:40 AM   #1
w9nl
 
w9nl's Avatar
Recipes 
 
Oct 2011
Oswego, IL
Posts: 11


Just hooked up a Auber 2362 PID and a Liquid tight K type, TC-K100M1/2NPT temp probe. I put the PID in a box and used a XLR connector on the temp probe so I could connect/disconnect as needed. I'm making the move to 10g batches and wanted to do a trial run of sorts tonight to see how things worked. I have the temp probe hooked up to the valve output of a keg I'm using as my MLT. I brought up abt 9g of water to 170 in my brew kettle and transferred to the mlt using a pump and then used the pump to recirculate the water thru the mlt. The PID is reading 177 which doesn't seem right so I grab my CDN digital thermometer and it is reading 160 which seems to make sense. I'm confused and shut everything down and go back and look at the manual. Figured I would recheck the settings to make sure the thermocouple is still set right in the PID. All OK there. Turn them pump back on and recheck the temp using the same 2 probes and everything now is spot on. So now I'm really confused. Any ideas?.

S


I

 
Reply With Quote
Old 04-27-2013, 10:35 PM   #2
orangehero
 
orangehero's Avatar
Recipes 
 
Apr 2010
Northeast
Posts: 1,748
Liked 306 Times on 193 Posts


You need a special connector for thermocouples, or just run it straight to the controller. If you use the K-type connector, you will also need to use K-type wire to run it to the controller. An XLR connector will work with an RTD but not a thermocouple.

http://www.auberins.com/index.php?ma...roducts_id=119

 
Reply With Quote
Old 04-28-2013, 12:21 PM   #3
w9nl
 
w9nl's Avatar
Recipes 
 
Oct 2011
Oswego, IL
Posts: 11

Thanks for the link to those connectors. I probably should have gone the RTD route to begin with. After scratching my head a little harder I finally read the note in the manual about not using copper wiring. Removed that and the XLR connector and went direct to the PID and all was good.

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Type M thermocouple, question. lakedawgs Electric Brewing 5 04-05-2013 01:55 PM
e-Bay PID K-Type Thermocouple Thread Question PaulHilgeman Brew Stands 5 09-28-2010 02:54 PM
HERMS build - Dual Thermocouple question 1000ml Brew Stands 5 09-24-2009 03:12 PM
This thermocouple?? kickflip_mj Equipment/Sanitation 3 04-03-2008 08:46 PM
Thermocouple or thermocouple wire source? e lo Equipment/Sanitation 22 11-08-2007 09:09 PM


Forum Jump