Ss Brewtech’s Biggest Baddest Holiday Giveaway Ever!

Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > Problem with fermentation??
Thread Tools
Old 04-09-2013, 11:34 PM   #1
Feedback Score: 0 reviews
Join Date: May 2011
Location: Pompton Lakes, New Jersey
Posts: 62
Default Problem with fermentation??

I made an ipa a few days ago. OG of 1.070. I usually double pitch wyeast or white labs but didn't this time and didn't make a starter. When I put the white labs in it came out clumped in the primary and now three days later haven't really seen any activity in the airlock. Could there be a problem??

msinning is offline
Reply With Quote
Old 04-10-2013, 02:34 PM   #2
Feedback Score: 0 reviews
Join Date: Feb 2013
Posts: 104
Liked 18 Times on 14 Posts


Lot of info missing here but if its worth anything. I pitched one vial wlp 001 on 1.092 no starter and obviously way under pitched. It kicked off in 3 hours and didn't finish for 3 weeks.
croakerj is offline
Reply With Quote

Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fermentation problem Sir_Alex Mead Forum 6 06-25-2012 07:24 PM
Fermentation problem hophead123 Fermentation & Yeast 1 05-24-2012 01:15 AM
No-Heat Mead - Fermentation Problem or Methodology Problem? matts Mead Forum 12 09-15-2011 10:11 PM
Fermentation Problem...please help merlin310 Beginners Beer Brewing Forum 10 05-27-2008 04:03 PM
fermentation problem?? wisconsinbrewer Beginners Beer Brewing Forum 1 02-07-2006 02:14 AM

Forum Jump

Newest Threads