Fermentation didn't start for five days - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > General Beer Discussion > Fermentation didn't start for five days

Thread Tools
Old 03-07-2013, 12:34 AM   #1
Netflyer's Avatar
Oct 2009
Near Benedict Maryland
Posts: 795
Liked 9 Times on 9 Posts

Hey, I've never had a fermentation take so long to start, used Wyeast British Ale Yeast which should ferment between 65 and 70 no problem... er.. I chilled er down and I guess my basement is colder than normal so it dropped to 61... without a heat belt I moved it upstairs to a warmer room but only got it to 63 in another day... finally after 5 days it's up to 66 and now it's fermenting like crazy. I know better than to open it and I figured if I wasn't seeing bubbles perhaps it was leaking somewhere...
So the question is, this has to be the yeast finally kicking in right? And, no I didn't make a starter, I'm lazy and the OG was only 1.045

RiClarke's Guinuess Clone w/da sour 6.4% ABV 1057 SG 1009 FG

Reply With Quote
Old 03-07-2013, 01:01 AM   #2
Nov 2012
State College, PA
Posts: 162
Liked 7 Times on 7 Posts

Sounds like you know the cause...cold. Now you will have to be careful that it doesn't over heat while fermenting.

Netflyer Likes This 
Reply With Quote
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Gravity - Fermentation didn't start MetuchenBrewerNJ Fermentation & Yeast 8 01-24-2011 04:08 PM
Fermentation didn't start brianroberts Fermentation & Yeast 34 12-02-2010 04:38 AM
Yeast didn't start, Now what? BobW44 General Techniques 4 08-15-2010 03:54 PM
Starter didn't start suspect Recipes/Ingredients 6 11-22-2008 02:26 PM
starter didn't start trubador General Techniques 18 01-22-2007 11:46 PM

Forum Jump