HBT 2015 Big Giveaway - This is it - Final Weekend to Enter!

Huge Supporting Membership Discounts - 20% Off - Final Weekend!

Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > Fermentation help needed
Reply
 
Thread Tools
Old 02-13-2013, 06:21 PM   #1
srattler
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2012
Location: Boise, Idaho
Posts: 6
Likes Given: 2

Default Fermentation help needed

A friend and I attempted a barley wine, I made a start using WPL099, 2 cups H20 and 1/2 cup of DME. It was on the stir [plate for 36 hours or so. Aggressive activity took place and the krausen was ~9 inches. Fermentation stopped at the 7th day..the issue is, OG was 1.098, FG indicated 1.076, this is less than 3%??? There's plenty of sugar left over (tasted it)......Any Ideas???

I racked it anyway and added 1 pkg LALVIN EC-1118 into the secondary yesterday....very slight activity after 24 hours...

Thanks!
srattler is offline
 
Reply With Quote
Old 02-14-2013, 08:24 AM   #2
rbenn
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2011
Location: , Michigan
Posts: 28
Liked 1 Times on 1 Posts
Likes Given: 1

Default

Its possible that you under pitched. 1.098 is a pretty high gravity and usually you need a couple liters of starter or multiple yeast packs. Check www.mrmalty.com/calc/calc.html and see how much yeast you need. Temperature could also affect the yeast if allowed to drop low enough but I doubt that was the issue.
rbenn is offline
srattler Likes This 
Reply With Quote
Old 02-14-2013, 10:14 AM   #3
chiteface
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2011
Location: Saugatuck, MI
Posts: 248
Liked 11 Times on 11 Posts
Likes Given: 1

Default

Were you using a hydrometer to measure?
chiteface is offline
srattler Likes This 
Reply With Quote
Old 02-15-2013, 02:47 PM   #4
srattler
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2012
Location: Boise, Idaho
Posts: 6
Likes Given: 2

Default

Morning...I don't believe I under pitched it...used a solid starter... see info below..

I did Use a hydrometer...

the recipe used:
120 minute boil
21 lb Wester 2-row
2 lb Crystal 30-37 L
1 lb Munich
3.5 oz Roast Barley

2 oz East Kent Goldings
3 oz Centenial

I mashed in at 155 for 60 minutes, conversion tested great..sparge temp 170 (about 6.5 gal of wort used). I thought my OG was a little light for a barleywine... I just did an IPA, OG was 1.1, and a double IPA, the OG was 1.14 (racked at 11.6 ABV), I've never had a problem with big beers till now. In comarisom to others I've made, wasn't that big??

I did the fermentation about 70 degrees, it fluctuates +/-1 degree....tried to spin method but didn't do anything, so I racked it, add the champagne yeast 48 hours ago, it's been outgassing 2 per second for the last 18 hours, keep your fingers crossed..LOL

I did taste it it's very very very sweet... I appreciate the replies.....

thanks
srattler is offline
 
Reply With Quote
Reply


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
no fermentation, suggestions needed WoofdogABC Beginners Beer Brewing Forum 5 07-01-2011 06:49 PM
fermentation chamber help needed OHIOSTEVE Beginners Beer Brewing Forum 10 06-10-2011 03:54 PM
Fermentation Done? Advice Needed. daytonlawvol Beginners Beer Brewing Forum 3 11-29-2010 01:23 PM
Is Secondary fermentation really needed??? mike1978 Beginners Beer Brewing Forum 41 11-17-2009 05:24 PM
Quick HElp needed on Fermentation eager_brewer Extract Brewing 3 03-29-2009 01:00 PM


Forum Jump

Newest Threads

LATEST SPONSOR DEALS