CO2 escapes big time when connect to regulator - Home Brew Forums
Register Now For Free!

Home Brew Forums > Home Brewing Beer > Bottling/Kegging > CO2 escapes big time when connect to regulator

Reply
 
Thread Tools
Old 12-07-2012, 02:46 AM   #1
desertsoilguy
Recipes 
 
Jan 2011
Gold Canyon, AZ
Posts: 18


I have had my kegorator for several years and no issues. Suddenly a CO2 cylinder ran out in less than a week. I had it filled, reattached it to my dual regulator, and no matter what I do CO2 rushes out (very noisy) when I open the cylinder. Have checked the connection with the regulator and it seems tight and secure. I closed the shutoff value on the regulator and turned the adjusting knob to the fully counterclockwise position (zero pressure setting). This is quite frustrating - any suggestions?

 
Reply With Quote
Old 12-07-2012, 02:53 AM   #2
Yooper
Ale's What Cures You!
HBT_ADMIN.png
 
Yooper's Avatar
Recipes 
 
Jun 2006
UP of Michigan, Winter Texan
Posts: 69,741
Liked 8016 Times on 5602 Posts


Quote:
Originally Posted by desertsoilguy View Post
I have had my kegorator for several years and no issues. Suddenly a CO2 cylinder ran out in less than a week. I had it filled, reattached it to my dual regulator, and no matter what I do CO2 rushes out (very noisy) when I open the cylinder. Have checked the connection with the regulator and it seems tight and secure. I closed the shutoff value on the regulator and turned the adjusting knob to the fully counterclockwise position (zero pressure setting). This is quite frustrating - any suggestions?
do you still have the plastic washer that fits between the regulator and the stem of the c02 tank? If it's intact, and in good shape, then I don't know. But I'd check that out first!
__________________
Broken Leg Brewery
Giving beer a leg to stand on since 2006

 
Reply With Quote
Old 12-07-2012, 03:00 AM   #3
mikescooling
 
mikescooling's Avatar
Recipes 
 
Jan 2012
Chicago, IL
Posts: 2,007
Liked 270 Times on 204 Posts


2nd... no washer or o ring...

 
Reply With Quote
Old 12-07-2012, 04:33 AM   #4
desertsoilguy
Recipes 
 
Jan 2011
Gold Canyon, AZ
Posts: 18

Thanks for the advice. Will double check the washer.

 
Reply With Quote
Old 12-07-2012, 05:49 PM   #5
desertsoilguy
Recipes 
 
Jan 2011
Gold Canyon, AZ
Posts: 18

Problem solved (I hope). The regulator in question is Taprite 542 made for Beverage Factory which up to now has performed very well. I took another look at the built-in plastic washer and noticed it was a little loose. Tightened it down with a screwdriver and it looks like I am back in business. Will check it each time I get a new C02 refill from now on.

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to connect a thermocouple? Cromwell Electric Brewing 10 10-28-2012 08:07 PM
First Time Kegger Doesn't understand his CO2 regulator! Beer-Baron Bottling/Kegging 7 05-31-2010 02:50 AM
how to connect these parts TipsyDragon Equipment/Sanitation 5 01-22-2010 04:43 PM
Sparge arm help. Connect to lid? mr_tripp All Grain & Partial Mash Brewing 4 01-07-2010 11:59 PM
Can't connect to Chat Sherpa FE General Chit Chat 1 05-23-2008 12:07 AM


Forum Jump