Carbonation issue in keg - Home Brew Forums
Register Now For Free!

Home Brew Forums > Home Brewing Beer > Bottling/Kegging > Carbonation issue in keg

Reply
 
Thread Tools
Old 12-03-2012, 02:34 AM   #1
hbrew85
Recipes 
 
Jul 2012
Tulsa, ok
Posts: 37


I have kegged a beer about a month ago. Primed it with 1/2 cup of dextrose. Just tapped it now and beer pours very foamy. When I pour it its nothing but foam but beer is flat. I am kinda new to kegging. Its my 10th keg and I have primed every keg this same way with 1/2 cup of dextrose. And it all worked just fine. This is the first keg that I got a problem with. Any ideas???

 
Reply With Quote
Old 12-16-2012, 10:09 PM   #2
hbrew85
Recipes 
 
Jul 2012
Tulsa, ok
Posts: 37

Never mind on that. I guess beer wasnt cold enough. Next day it wasnt foaming that much and it was carbonated just fine. Never seen it before. Maybe it happens when keg is primed

 
Reply With Quote
Old 12-16-2012, 10:10 PM   #3
RobertRGeorge
Recipes 
 
Jul 2012
Nelson, Bc
Posts: 537
Liked 49 Times on 39 Posts


I don't sugar-prime kegs but I've read that 1/3 of a cup is adequate. I also weigh any priming sugar because there can be a variation based on how well it is packed into the measuring vessel.

 
Reply With Quote
Old 12-16-2012, 10:15 PM   #4
hbrew85
Recipes 
 
Jul 2012
Tulsa, ok
Posts: 37

I tried 1/3 before and it didnt work out for me but 1/2 is perfect. Some people even do 3/4 cup.

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carbonation Issue Suilesre Beginners Beer Brewing Forum 9 11-27-2012 07:59 PM
Carbonation issue klearn Beginners Beer Brewing Forum 3 10-10-2012 01:03 AM
Odd Carbonation Issue Taypo Beginners Beer Brewing Forum 4 10-25-2011 07:56 PM
Carbonation issue... robpez Bottling/Kegging 2 07-24-2010 04:31 AM
Carbonation Issue . . . . IndyPABrewGuy Extract Brewing 14 07-30-2007 05:43 PM


Forum Jump