Teel pump connection not working out. ideas? - Home Brew Forums
Home Brew Forums > Home Brewing Beer > DIY Projects > Brew Stands > Teel pump connection not working out. ideas?

Reply
 
Thread Tools
Old 10-17-2012, 10:31 PM   #1
lnlogauge
Recipes 
 
Oct 2011
Hampton, GA
Posts: 45
Liked 1 Times on 1 Posts



I haven't posted very much, I prefer to do more reading and dreaming of projects in the DIY section.

Here's my setup.



Its pretty simple, but does the job. I have very little money invested into it, which is the best part. It was a combination of trading equipment for a welded stand I was able to get for a friend via a work connection, then a ridiculous craigslist deal that provided a few parts, and sold off the rest.

In the craigslist deal, I acquired a teel pump. The pump works great, but the connection that the pump offers is not great.



Ive brewed a couple of times and hose clamped on a 3/4 hose, to a mcmaster fitting like the rest of the system, but it doesnt work that great. heat makes the hose sag, and it looks like ass. As many people that are on here, surely someone has come up with an ingenious solution.

Ideally i'd like to put my 6 spare copper valves to work with a manifold and make it where I dont have to disconnect anything while brewing, but I'm not convinced the copper manifold would clean like I want it to. Money is holding me back from going stainless, as the wife and I are putting all spare money to getting out of debt.



 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pond Pump Wort Chiller Connection Instructions BrewThruYou Chillers & Stir Plates 14 02-20-2014 11:13 PM
QD and pump not working Chrisharvey Equipment/Sanitation 1 07-20-2012 04:38 AM
Help! My chugger pump just isn't working out. . . czucker Brew Stands 29 01-31-2011 05:51 PM
March pump connection questions drunkatuw Equipment/Sanitation 5 10-01-2008 11:28 PM
CFC pump connection ddknight Equipment/Sanitation 2 02-20-2008 03:42 PM


Forum Jump