My chimay red clone did not carbonate - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > Bottling/Kegging > My chimay red clone did not carbonate

Thread Tools
Old 09-21-2012, 01:26 AM   #1
Aug 2012
Houston, Tx
Posts: 59

I tried my first bottle of a chimay red clone. It fermented for 30 days and hit the final gravity as it should. I added sugar acording to The beer recipitator web site .

19 days after bottling i opened my first bottle. It had little to no cabonation and was on the sweet side. It has been at about 66 degrees after bottling.

What do i do now?

Reply With Quote
Old 09-21-2012, 06:17 AM   #2
nebben's Avatar
Nov 2008
Now legal in Utah
Posts: 1,145
Liked 11 Times on 11 Posts

What was your OG, FG, and what yeast did you use? It is possible that it just needs some more time.

Reply With Quote
Old 09-21-2012, 07:04 AM   #3
Aug 2011
Cork, Cork
Posts: 439
Liked 17 Times on 13 Posts

I have had strong dark belgians that didn't carbonate for 2 months. May the patience be with you.
4499L brewed since August 2011.

Reply With Quote
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can you re-carbonate beer that didn't carbonate well in bottles? olharris Bottling/Kegging 23 08-11-2016 05:10 PM
Re-using 75cl Chimay bottles...caps possible? climateboy Bottling/Kegging 6 09-18-2012 11:51 PM
Chimay Clone - Reuse Bottles? Joeywhat Bottling/Kegging 6 01-21-2011 02:39 PM
how to carbonate a keg? mattrobertson Bottling/Kegging 9 01-03-2011 10:16 PM
De-Carbonate a keg kypher Bottling/Kegging 2 07-30-2010 07:16 AM

Forum Jump