ebay PID - Page 2 - Home Brew Forums
Register Now For Free!

Home Brew Forums > Home Brewing Beer > Electric Brewing > ebay PID

Reply
 
Thread Tools
Old 10-03-2012, 09:35 PM   #11
stlbeer
Senior Member
HBT_SUPPORTER.png
 
stlbeer's Avatar
Recipes 
 
Jan 2008
Fenton, MO
Posts: 1,023
Liked 46 Times on 45 Posts


Quote:
Originally Posted by migraine View Post
I too, have a TA6 and I'm having problems with the programing and of course, there is no help from the company that sold it or the manufacturer.

I have been able to wire it correctly, and set a heating temp. When checking to see if it's working, I am using a light buld instead of a heating element.
when it is heating towards the required temp, the light stays on. But, within 10* of the target temp, the light bulb begins to flash untill it reaches temp and then shuts off.

I realize that if the bulb is flashing on and off, then the current would be doing the same to a heating element, and worse, it will cause premature failure to the solid state relay.

Can somone please tell me where I am going wrong???
Thanks in advance,
Brian
916-804-0175
What you are explaining is what appears to be normal PID operation. You do realize that the goal of the PID is to hit the requested temperature without overshooting it? When you get your system built you need to tune your PIDs to work with your system. There should be an autotune feature. The PID uses calculus to determine the heat curve (how much heat your rig can put into the system). If it ran full bore then turned off at the setpoint then it would overshoot (normal thermostat functions like this). With a PID, when the setpoint is near, the PID will start modulating on/off duration in the Cycle time (usually 2 seconds) so that it slowly reaches the setpoint without overshooting it. When it starts flashing it will be on longer than off, then as it gets closer it will be off longer than on. SSR's were designed to be cycled frequently. It's for this reason they exist as they are better at this than mechanical relays (aka contactors).
__________________
My RIMS eBrewery build

 
Reply With Quote
Old 10-03-2012, 11:18 PM   #12
jasonsbeer
 
jasonsbeer's Avatar
Recipes 
 
Jul 2009
Central Iowa
Posts: 390
Liked 24 Times on 14 Posts


Quote:
Originally Posted by migraine View Post
I too, have a TA6 and I'm having problems with the programing and of course, there is no help from the company that sold it or the manufacturer.
There shouldn't be any manual programming involved. Use auto tune to self-program. I believe you hold in the "<</AT" button for 3 secs to initiate auto tune. The AT light will come on during auto tuning.

Only thing I manually changed on my TA4 was to display deg F. Working great.
__________________
There are a terrible lot of lies going around the world, and the worst of it is half of them are true.

Winston Churchill

 
Reply With Quote
Old 10-04-2012, 03:48 AM   #13
migraine
Recipes 
 
Oct 2012
Sacramento, Ca
Posts: 2

Quote:
Originally Posted by SleepyCreekBrews View Post
I have 2 of the MyPin TA6 Pids that come with the type K and the 25A SSR, they've been working OK ...as I recall the package was $35
would you care to help me with the same unit(s)? I have no experience with programining these and mine cycles on/off every second when it is with in 10 degrees of the target temp.
I am trying htis unit out on my electric smoker, before getting into brewing with my brother(only extracts in the past, but everyone has to start somewhere)
thanks, Brian

 
Reply With Quote
Old 12-03-2012, 05:21 AM   #14
dancon
Recipes 
 
Jun 2012
Posts: 3

I have a my pin ta5, it is all wired up and running but the signal will not go to the SSR, the light on the pid is on but nothing on the SSR.

Any suggestions?

 
Reply With Quote
Old 12-03-2012, 02:04 PM   #15
stlbeer
Senior Member
HBT_SUPPORTER.png
 
stlbeer's Avatar
Recipes 
 
Jan 2008
Fenton, MO
Posts: 1,023
Liked 46 Times on 45 Posts


The signal lines are switched? Pos to neg and Neg to pos instead of pos to pos and neg to neg? Or maybe a bad SSR.
__________________
My RIMS eBrewery build

 
Reply With Quote
Old 12-05-2012, 09:36 PM   #16
jCOSbrew
Recipes 
 
Feb 2012
Colorado Springs, CO
Posts: 619
Liked 38 Times on 34 Posts


@migraine: If you don't want the PID to modulate the out close to the process temp, change it to ON/OFF mode instead of PID mode. This will provide full power until you hit the process temp.

@dancon: Make sure you are setup for SSR output mode, some models have several options for relay, SSR, 4-20ma output, etc. When it is setup correctly, you should be able to measure DC voltage (12V?) across the SSR output pins when the PID output is turned on.

 
Reply With Quote
Old 12-06-2012, 12:31 PM   #17
dancon
Recipes 
 
Jun 2012
Posts: 3

I am on SSR mode (setting is 001, I also tried the other settings), the relay works, checked it with a 9v. Are there other settings that could be causing this? I have two PIDs and two SSRs, and tried them all and no luck. I must be doing something wrong. Thanks in advance for your help/advice.

 
Reply With Quote
Old 12-06-2012, 03:54 PM   #18
jCOSbrew
Recipes 
 
Feb 2012
Colorado Springs, CO
Posts: 619
Liked 38 Times on 34 Posts


You say you have a relay output that works.
Do you have "-RNR" model or the "-SNR" model? What is the full P/N?
R = Relay output, S = SSR output.

 
Reply With Quote
Old 12-06-2012, 07:32 PM   #19
dancon
Recipes 
 
Jun 2012
Posts: 3

This is what I have:
AGPtekŪ Universal Digital PID Temperature Controller RNR Control Out Dual display For Fahrenheit(F) and Celsius(C)
http://www.amazon.com/gp/product/B00...ls_o02_s00_i00

Amico DC to AC Single Phase Solid State Relay SSR-40DA 40A 90-480V AC + Heat Sink
http://www.amazon.com/gp/product/B00...ls_o03_s00_i01

 
Reply With Quote
Old 12-06-2012, 10:05 PM   #20
stlbeer
Senior Member
HBT_SUPPORTER.png
 
stlbeer's Avatar
Recipes 
 
Jan 2008
Fenton, MO
Posts: 1,023
Liked 46 Times on 45 Posts


I think you just found your answer. -RNR is for a mechanical relay. -SNR is for a SSR.

The ebay ad is misleading. I say call the seller and see if they will exchange the -RNR for a -SNR.
__________________
My RIMS eBrewery build

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
$46 spa panel on ebay tjash Electric Brewing 1 09-01-2012 05:11 PM
Ebay PID lzrdkng14 Electric Brewing 10 02-24-2012 02:46 PM
Ebay SSR runs4beer Electric Brewing 50 02-16-2012 02:31 AM
Ebay RTD smellysell Electric Brewing 10 07-06-2011 09:40 PM
Ebay PID... is it ok? kklowell Electric Brewing 4 11-13-2010 02:03 AM


Forum Jump