Coldbreak Brewing HERMS Giveaway!

HomeBrewSupply AMCYL Brew Kettle Giveaway!


Home Brew Forums > Home Brewing Beer > Lambic & Wild Brewing > Flanders Red Primary Lag
Reply
 
Thread Tools
Old 04-29-2012, 11:30 PM   #1
rp5brew
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2010
Location: Tacoma, WA
Posts: 54
Default Flanders Red Primary Lag

BT Homies!!

I brewed my first Flanders red last weekend- was planning on fermenting it with 100% RRBC "Supplication" Dregs. I propagated the dregs (3 bottles) with 750 ml 1.040 amber DME.
my first mistake: I put the propagation on my stir plate.

I let the propagation ferment for a month and then split it and pitched into the Flanders. Day one:

Click image for larger version

Name:	image-1312102924.jpg
Views:	64
Size:	23.0 KB
ID:	59391


After 5 days of no activity, this popped up:





Click image for larger version

Name:	image-4187708403.jpg
Views:	65
Size:	58.4 KB
ID:	59395



Click image for larger version

Name:	image-1651174027.jpg
Views:	75
Size:	30.1 KB
ID:	59396


So then I decided to go with plan B: I harvested 100ml of wyeast 1056 from my conical and poured 50 ml of slurry in each. After 15 hours we come to this:


Click image for larger version

Name:	image-1761808693.jpg
Views:	65
Size:	23.9 KB
ID:	59397


Here is the question: what will come of the mold? Do I need to make plans to rack this and then add more bugs?


rp5brew is offline
 
Reply With Quote
Reply


Thread Tools



Forum Jump

Newest Threads

LATEST SPONSOR DEALS