Problems with my IPAs - Page 4 - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > All Grain & Partial Mash Brewing > Problems with my IPAs

Reply
 
Thread Tools
Old 05-29-2012, 05:56 AM   #31
KuntzBrewing
Recipes 
 
Aug 2011
Kokomo, Indiana
Posts: 630
Liked 14 Times on 13 Posts


Also on my latest ipa I cut my water in half with distilled water that was charcoal filtered and added 5g Gypsum only to mash. Haven't bottled yet but it sure smells great and no off flavors in the hydro tube I sampled

 
Reply With Quote
Old 05-29-2012, 03:03 PM   #32
ChillWill
Recipes 
 
Jan 2011
Sheffield, South Yorkshire
Posts: 869
Liked 23 Times on 19 Posts


I'd suggest too many sulphates are upsetting your system, then you're using a load of water from your body to try and dilute them which is giving you a bad head ache.

As to why you're not getting sick after they've conditioned more I don't know. The only thing that could be is more yeast in suspension. Magnesium is only really needed for yeast health so adding that is pretty pointless as they don't need much at all.

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
First all-grain...problems, problems, problems. Q2XL All Grain & Partial Mash Brewing 30 09-13-2013 11:02 PM
Few problems with my AG DoubleFisted All Grain & Partial Mash Brewing 3 03-07-2011 07:54 PM
Low OG problems kypher All Grain & Partial Mash Brewing 13 01-02-2010 05:38 PM
A/C problems hopsalot All Grain & Partial Mash Brewing 3 06-18-2008 08:00 PM
Hop shortages are no good for IPAs! MayoIsEvilBeerIsGood All Grain & Partial Mash Brewing 17 02-02-2008 03:59 PM


Forum Jump