Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > Trouble shooting "heat tape" (flexwatt/fermwrap)
Reply
 
Thread Tools
Old 03-10-2012, 06:20 PM   #1
GhettoDickens
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2011
Location: Boulder, Co
Posts: 35
Default Trouble shooting "heat tape" (flexwatt/fermwrap)

I got a flexwatt heater from my local homebrew store. When I plugged it into my temperature control device, it was not warm after 30 mins. I then plugged the flexwatt straight into the wall, and still no warmth after 30 minutes.

I am really at a loss what to do, since there does not seem to be a manufacturer of this item with FAQ/troubleshooting information. Furthermore I am not very electrically savvy so I am not really sure what to be checking.

Any help would be greatly appreciated since my saison is sitting at 68 instead of 80 right now!


GhettoDickens is offline
 
Reply With Quote
Reply


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
2" x 2" x 1/16" mild steel for single-tier? Dustin_J Equipment/Sanitation 9 06-05-2012 07:03 AM
Teflon tape exposed on 1/2" male NPT thread on inside of kettle julian81 Equipment/Sanitation 2 02-01-2011 01:25 PM
banner "perfecta line" vinyl tubing temp rating? Peace11uehman Equipment/Sanitation 3 01-28-2011 03:36 PM
DIY Mash Tuns: Pros and cons of cube vs. "gatorade" style? moxie Equipment/Sanitation 29 06-15-2010 01:40 AM
"Do Not Bump or Heat" FSBrewer Equipment/Sanitation 5 07-12-2008 06:11 PM


Forum Jump

Newest Threads

LATEST SPONSOR DEALS