Home Brew Forums > Recipe Database > HomeBrewTalk.com Recipe Database > Wine > General Concentrate Wine

Reply
 
Thread Tools
Old 04-21-2013, 03:04 PM   #171
lpsumo
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2012
Posts: 75
Liked 5 Times on 4 Posts
Likes Given: 1

Default


I can't get this to go...

I made 1 gallon, used 1 can mango and 1 can cranberry. KV-1116

Started it a month ago, OG was 1095. Got a few bubbles but not much

Checked it the other day, gravity was about the same (1090 maybe?) so I pulled off 500ml of it and added 500ml water. Gave it 2 more days and nothing happened. Poured off another 500ml and topped it up with water.

2 days later, still no action.

Any thoughts on this?
lpsumo is offline  
 
Reply With Quote
Old 04-21-2013, 03:43 PM   #172
mattsilf
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2013
Posts: 46
Default


How much sugar did you use? 2 pounds?
mattsilf is offline  
 
Reply With Quote
Old 04-21-2013, 04:23 PM   #173
lpsumo
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2012
Posts: 75
Liked 5 Times on 4 Posts
Likes Given: 1

Default


yes, 2 pounds sugar, and 1/2t nutrients
lpsumo is offline  
 
Reply With Quote
Old 04-21-2013, 08:28 PM   #174
mattsilf
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2013
Posts: 46
Default


Sometimes people have problems with that much sugar. I was one of them. I ended up pitching more yeast with nutrient and energizer to get mine going again. Its still going VERY slow....i made a small batch using this recipe but used half the sugar(1 lb per gallon) and it was down to 1.00 in less than a week.
mattsilf is offline  
 
Reply With Quote
Old 04-21-2013, 08:30 PM   #175
mattsilf
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2013
Posts: 46
Default


I always use Montrachet btw.
mattsilf is offline  
 
Reply With Quote
Old 04-22-2013, 02:04 AM   #176
lpsumo
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2012
Posts: 75
Liked 5 Times on 4 Posts
Likes Given: 1

Default


Thanks for the tip, I'll give it another day and then maybe add some new yeast. I've got an EC-1118 starter going right now for a skeeter pee that never took off so maybe I'll just use some of that.
lpsumo is offline  
 
Reply With Quote
Old 04-23-2013, 12:16 AM   #177
mattsilf
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2013
Posts: 46
Default


Just fyi, when i added more yeast and energizer/nutrient, it bubbled something fierce and almost came out the top of the carboy lol
mattsilf is offline  
 
Reply With Quote
Old 04-23-2013, 12:56 AM   #178
brazedowl
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jul 2009
Location: Fayetteville, NC
Posts: 849
Liked 35 Times on 26 Posts
Likes Given: 9

Default


Quote:
Originally Posted by mattsilf View Post
Just fyi, when i added more yeast and energizer/nutrient, it bubbled something fierce and almost came out the top of the carboy lol
Haha the crystals just provided nucliation points for the dissolved gas to form bubbles most likely.
__________________
In Progress: White Clover Wine
In Progress: Blueberry Wine (1)
In Progress: Fresh Fig Wine
In Progress: Ginger Spiced Cider
Bottled: oodles and oodles
______________________

"What senses do we lack that we cannot see or hear another world all around us?"
brazedowl is offline  
 
Reply With Quote
Old 04-23-2013, 01:04 AM   #179
mattsilf
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2013
Posts: 46
Default


It looked like a science project volcano! Haha
mattsilf is offline  
 
Reply With Quote
Old 05-05-2013, 11:19 PM   #180
jpm5171988
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2010
Location: Cypress
Posts: 39
Default


Status update: fermentation went well (used white labs sweet mead yeast) for the first week or so. SG was 1.105 and came down to 1.030 before getting stuck. I find this a little odd because the yeast I used can handle up to 15% abv, and I'm currently around 10%. Fermentation temps where kept in the optimum range throughout the entire process. Any ideas as to why this happened? In an attempt to get things moving again I removed some of the wine, added yeast nutrient and energizer and gently mixed it back in. This did absolutely nothing. After waiting almost a week, gravity had dropped only 2 points. Any ways, I just bought some more yeast and made a starter...just waiting for things to take off before I repitch. I will keep you guys updated.
jpm5171988 is offline  
 
Reply With Quote
Reply


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strawberry Wine Brewerone Wine 14 01-14-2015 05:39 PM
Pomegranate Wine shadows69 Wine 15 01-25-2013 06:44 PM
Cherry Wine summersolstice Wine 19 08-26-2012 06:58 AM
Blueberry Wine brazedowl Wine 0 12-17-2011 04:35 PM
Apple Wine raynor Wine 7 02-18-2010 02:42 AM


Forum Jump

Newest Threads

LATEST SPONSOR DEALS