anyone else had this problem - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > anyone else had this problem

Thread Tools
Old 12-09-2011, 02:43 AM   #1
noodle23's Avatar
Jan 2011
calistoga, ca
Posts: 293
Liked 3 Times on 3 Posts

So i just got my new Jaybird false bottom and i'm having some trouble getting it to fit with my copper dip tube from bargain fittings. maybe there is an order of operations to putting the pieces together that im over.The dip tube is attached to the bulk head when i try to get it in the hole of the false bottom (i know im setting my self up for something there). Then when i get it in there i cant get the bulk head to seal so it leaks. What do you think is the problem?
I would like to live in theory, everything works in theory.

Pork Chops taste good, bacon taste good.

Reply With Quote
Old 12-09-2011, 10:58 PM   #2
Schnitzengiggle's Avatar
Feb 2009
Tucson, AZ
Posts: 2,560
Liked 31 Times on 23 Posts

Perhaps the dip tube is too long/short and is applying pressure on the weldless fitting causing a leak.
follow me @ Broken Glass Brewery

Okham's Razor - simplest explanation is usually the correct one.

My DIY Kegerator - My DIY Fermentation Chamber - My DIY Portable Pump Box

Reply With Quote
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Keezer problem EKennett Equipment/Sanitation 2 12-05-2010 01:20 PM
Vinator problem HopEd Equipment/Sanitation 6 03-29-2009 05:54 PM
Told that I have a problem springer Equipment/Sanitation 2 03-20-2009 03:45 PM
Keezer Problem Rockweezy Equipment/Sanitation 7 03-10-2009 07:56 AM
MLT problem Adam's Apples Equipment/Sanitation 6 09-25-2008 05:17 PM

Forum Jump