my wheat with wyeast 1010 still smells like a butthole - Home Brew Forums
Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > my wheat with wyeast 1010 still smells like a butthole

Reply
 
Thread Tools
Old 08-11-2011, 03:24 AM   #1
Rolly
Recipes 
 
Sep 2010
Petaluma, CA
Posts: 115
Liked 2 Times on 1 Posts



It has been six weeks and carbed in the keg for three weeks. If the sulfur aroma and taste doesn't go away in the next 2 weeks I'm gonna have to water the lawn with it to make room for something else.



 
Reply With Quote
Old 08-11-2011, 03:26 AM   #2
lumpher
Recipes 
 
Jul 2009
texas
Posts: 5,063
Liked 264 Times on 225 Posts


what temp was it fermented at?


__________________
There is no "i" in denial.

 
Reply With Quote
Old 08-11-2011, 03:43 AM   #3
Rolly
Recipes 
 
Sep 2010
Petaluma, CA
Posts: 115
Liked 2 Times on 1 Posts


Quote:
Originally Posted by lumpher
what temp was it fermented at?
I pitched at 62, fermented at 66, then raised to 70 for D-rest. Everything process wise was textbook, its just the first time I've used this yeast and I guess me no likey.

 
Reply With Quote
Old 06-18-2012, 03:30 AM   #4
wittmania
Recipes 
 
Oct 2010
Lincoln, NE
Posts: 215
Liked 5 Times on 5 Posts


Sorry to resurrect this thread, but did the beer ever improve?
__________________
wittmania.com

 
Reply With Quote
Old 06-19-2012, 12:57 AM   #5
tgmartin000
Recipes 
 
May 2011
Denver, CO
Posts: 1,251
Liked 87 Times on 72 Posts


My experience was that I got some sulfur at 68, but I quickly lowered the temp, and never detected any sulfur in the finished product.



 
Reply With Quote
Reply
Thread Tools



Forum Jump