Working on first keg. - Home Brew Forums
Home Brew Forums > Home Brewing Beer > Bottling/Kegging > Working on first keg.

Reply
 
Thread Tools
Old 09-28-2005, 10:37 AM   #1
ScottT
 
ScottT's Avatar
Recipes 
 
Aug 2005
Hurst, Tx
Posts: 653
Liked 1 Times on 1 Posts



Got my first keg and am working on getting it ready. I've got it completely disasembeled except for the popet valve. How the heck do you get it out of there. It looks like it's pressed in. I don't want to force it out unless that's the only way.

BTW the keg is a Firestone Challenger VI. It has had root beer in it and I'm replacing all the rubber in the thing.


__________________
Scott

Primary: Empty

Secondary #2: Empty

Bottle Conditioning: Oatmeal Stout

Drinking from Keg: Ordinary Bitter, Kolsch

Drinking bottled: Brown Autumn Wee Heavy
Hefe Weizen
Peaches and Cream Weizen


"This is grain, which any fool can eat, but for which the Lord intended a more divine means of consumption... Beer!"
-Robin Hood, Prince of Thieves, Friar Tuck.

Next up: Hefe Weizen

 
Reply With Quote
Old 09-28-2005, 12:28 PM   #2
tnlandsailor
 
tnlandsailor's Avatar
Recipes 
 
Apr 2005
Knoxville, TN
Posts: 522
Liked 15 Times on 12 Posts


Take the fitting off the keg. Place the fitting on a towel with the poppet button facing upward. Using a small rod, maybe a key or a small wooden dowel, something about the diameter of the button, push straight down on the button. It will give a little as the spring compresses but keep pushing down (carefully). Eventually, it will dislodge and snap down (hence the reason for the towel).

Prosit!
__________________
Prosit!

Hands-On Brewing

Dennis Collins
Knoxville, TN
Innovative Homebrew Solutions
Home of the Hop Stopper!
www.ihomebrewsolutions.com

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
working without a net Daddymem Beginners Beer Brewing Forum 2 04-09-2009 07:29 PM
How do I know if it's working. frijole Beginners Beer Brewing Forum 12 01-27-2009 03:10 AM
Is my PID working??? gtg644w Brew Stands 2 10-22-2008 03:20 AM
Something I've been working on.... Dude Label Display & Discussion 9 02-19-2007 05:57 PM
Reg not working right Jester4176 Bottling/Kegging 3 06-13-2006 03:29 AM


Forum Jump