pump questions - Home Brew Forums
Register Now For Free!

Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > pump questions

Reply
 
Thread Tools
Old 05-01-2011, 06:28 PM   #1
rhltechie
 
rhltechie's Avatar
Recipes 
 
Aug 2009
SC
Posts: 206
Liked 1 Times on 1 Posts



hey all,

i read through some of the threads....i had to, just to get the hang of getting my pump primed to begin with. questions......i am still doing extract until i get this whole new process down. so right right i prime right at the beginning when i boil a little water to sanitize my pump/chiller. once i have the pump primed, and i just supposed to leave the power going continuously with the output closed? seems like such a waste of power.

also....what happens if i lose prime in the middle....has happened already a few times.....maybe i havent read enough threads!!

TIA,

M
__________________

Tap 1: Stone IPA Clone
Keg 2: nothing :(
Primary: nothing :(
Secondary: Belgian White
Next Brew: Stella Artois Clone


My Brewing Beast Build
DIY Ferm Chamber
DIY Kegerator

 
Reply With Quote
Old 05-01-2011, 06:36 PM   #2
rosier9
Recipes 
 
Dec 2010
Bellevue, NE
Posts: 183
Liked 2 Times on 2 Posts


no you don't need to leave the power running to maintain prime... if you lose prime it shouldn't be difficult to get it back by flooding the inlet with the outlet open (pump off)...
__________________
Kegged: Amarillo Ale, Edwort's Apfelwein, Golden Dragon, 1554, 888 RIS
Primary:

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Little Giant Pump 3-MD-HC Questions Nerdie Equipment/Sanitation 16 09-22-2011 06:11 PM
march pump questions Funkenjaeger Equipment/Sanitation 7 07-11-2010 09:33 PM
First Time Pump Questions Rudeboy Equipment/Sanitation 5 04-20-2010 05:03 AM
Pump use questions Stevorino Equipment/Sanitation 10 05-04-2009 04:38 PM
Pump Questions! Stevorino Equipment/Sanitation 24 02-02-2009 09:07 PM


Forum Jump