Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > wlp500 ?'s
Reply
 
Thread Tools
Old 03-20-2011, 12:00 PM   #1
tchuklobrau
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Gowanda, NY
Posts: 1,007
Liked 15 Times on 14 Posts
Likes Given: 2

Default wlp500 ?'s

I am making a belgian dubbel and using wlp500 trappist yeast for it. I made a 2l starter(my 4th) exactly the same as all the others I have made. Unlike all the others 24hours on a stirplate and i have nothing. Bad vial of yeast? Or is wlp500 slow to get going?


tchuklobrau is offline
 
Reply With Quote
Old 03-20-2011, 01:12 PM   #2
Hammy71
Senior Member
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
Hammy71's Avatar
Recipes 
 
Join Date: Sep 2008
Location: , Maryland, The Tax Me State
Posts: 5,810
Liked 493 Times on 374 Posts
Likes Given: 766

Default

Stop your stirplate and let the yeast settle. I bet it's there. WLP500 doesn't seem to foam up a lot for me. Some yeast are faster than others. I usually try to make my starters 3-4 days before I brew, with the last day in the fridge.
Hammy71 is offline
 
Reply With Quote
Reply


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent experience with WLP500 Chimay Strain meadowstream Fermentation & Yeast 6 12-23-2010 07:25 PM
Uses for WLP500 permo Fermentation & Yeast 7 09-24-2010 06:25 PM
WLP500 (Chimay) Alcohol Tolerance permo Fermentation & Yeast 4 09-22-2010 06:25 PM
WLP500 and other Belgian yeasts Shaggyt Fermentation & Yeast 6 04-09-2010 12:27 AM
Help with WLP500 for FG and bottle conditioning. togabear Fermentation & Yeast 5 12-14-2009 11:43 PM


Forum Jump

Newest Threads

LATEST SPONSOR DEALS