Chugger pump issue - Home Brew Forums
Register Now For Free!

Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > Chugger pump issue

Reply
 
Thread Tools
Old 02-14-2011, 05:03 PM   #1
JMichael
HBT_SUPPORTER.png
Recipes 
 
Jun 2010
NC
Posts: 66


So, I have two chugger pumps and both worked very well up until a couple of weeks ago when one started locking up. By locking up, I mean the impellor will just freeze after about 20 minutes. The motor still runs but the pump quits.

Mike at chugger says it's because I need full port 1/2 ID quick disconnects because the 3/8 qd's cause cavitations which makes the pump impellor spin out against the pump head and lock up.

Anyone else have this issue? My other pump (chugger ) doesn't do this and the QD's are the same throughout the entire system.

Anyone know where to get full ported 1/2 QD's?

 
Reply With Quote
Old 02-14-2011, 05:13 PM   #2
Bobby_M
Vendor and Brewer
HBT_SPONSOR.png
 
Bobby_M's Avatar
Recipes 
 
Aug 2006
Whitehouse Station, NJ
Posts: 23,330
Liked 1765 Times on 1122 Posts


The camlocks are 1/2" all the way through as long as you avoid the one with the integrated barb.
__________________
Welcome to BrewHardware.com. I love you.
New Stirplates are IN!
Chugger Pumps, Pump Kits, Camlocks, Sightglasses, Clear USA made Silicone Tubing, RIMS, Electric Install Parts, etc.

 
Reply With Quote
Old 02-14-2011, 05:18 PM   #3
Flomaster
 
Flomaster's Avatar
Recipes 
 
Nov 2010
Orange, Ca
Posts: 2,149
Liked 38 Times on 35 Posts


I use 1/2" camlocks and no issues as of yet.

-=Jason=-

 
Reply With Quote
Old 02-14-2011, 05:19 PM   #4
samc
Recipes 
 
Aug 2008
Portland OR
Posts: 5,387
Liked 63 Times on 59 Posts


I don't buy the qd issue on this particular problem as you have been using it without issue up until now. Read this thread on March pumps, see post #20 http://www.homebrewtalk.com/f11/warn...4/#post2601515 You might be able to do something like that with the Chugger. Give it a good cleaning first and test. You don't have much to lose before spending $$ on QD's.

 
Reply With Quote
Old 02-14-2011, 05:25 PM   #5
Hogcrewer
 
Hogcrewer's Avatar
Recipes 
 
Oct 2005
North Pole, AK
Posts: 68

Hhhmm, I purchased a head unit from him for my 809 and running the McMasters-Carr QD's and havent had a issue with this yet. It will occasionally make a squealing noise when it first starts up. But I contribute that to air in the head.
__________________
Das grasse Bier aus der klieinen Brauerei.

 
Reply With Quote
Old 02-15-2011, 01:41 AM   #6
JMichael
HBT_SUPPORTER.png
Recipes 
 
Jun 2010
NC
Posts: 66

Thanks guys!

Sam, in that thread it says that the sugars can cause this. This particular pump is used between my HLT and MLT and only moves water.

 
Reply With Quote
Old 02-15-2011, 01:44 AM   #7
JMichael
HBT_SUPPORTER.png
Recipes 
 
Jun 2010
NC
Posts: 66

Quote:
Originally Posted by Hogcrewer
Hhhmm, I purchased a head unit from him for my 809 and running the McMasters-Carr QD's and havent had a issue with this yet. It will occasionally make a squealing noise when it first starts up. But I contribute that to air in the head.
I thought it might be air getting caught in the dip tube so I took it off but still had the same problem. It seems to only happen when the temps go over 160.

 
Reply With Quote
Old 02-15-2011, 01:47 AM   #8
WPStrassburg
Recipes 
 
Sep 2008
Rochester, NY
Posts: 592
Liked 38 Times on 33 Posts


These little pumps can't truly cavitate. They can't pull enough suction to create a vacuum low enough to cause cavitation. The pump may have air in the head or the heat may be causing some distortion in the head causing it to bind and lock the impeller up. Does the flow sputter or make any bubbles before it stops or does it just lock up? The casting looks less than stellar on most of these from what I've seen, so I'd suspect it's an alignment issue. Can you move the rear can relative to the front volute cover if you take the head off?

Try taking the qd's off an just recirc hot water with the hoses and see if it locks up. If so then it's an alignment issue.

 
Reply With Quote
Old 02-15-2011, 02:45 AM   #9
WPStrassburg
Recipes 
 
Sep 2008
Rochester, NY
Posts: 592
Liked 38 Times on 33 Posts


Check the alignment of the 4/6(volute) (ss chugger remake of the polysulfone/bronze march heads), 11, 12/13, and 14(rear can)
Page 2 for part # references.
http://www.marchpump.com/site/files/...ump_Manual.pdf

By the sounds of it it's just heating up and binding the impeller on the shaft, or the thrust washer(11) isn't in the right spot at the front of the impeller(14).

 
Reply With Quote
Old 02-15-2011, 02:53 AM   #10
mattd2
Recipes 
 
Sep 2009
Papamoa, New Zealand
Posts: 3,770
Liked 319 Times on 254 Posts


Quote:
Originally Posted by WPStrassburg View Post
These little pumps can't truly cavitate. They can't pull enough suction to create a vacuum low enough to cause cavitation. The pump may have air in the head or the heat may be causing some distortion in the head causing it to bind and lock the impeller up. Does the flow sputter or make any bubbles before it stops or does it just lock up? The casting looks less than stellar on most of these from what I've seen, so I'd suspect it's an alignment issue. Can you move the rear can relative to the front volute cover if you take the head off?

Try taking the qd's off an just recirc hot water with the hoses and see if it locks up. If so then it's an alignment issue.
What makes you say you can't get cavitation in these pumps? If you have enough restriction in the suction line and the vapour pressure is lowered due to it being hot water I could see it possible to cavitate the pump. Just saying.

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stuck Chugger Pump Scut_Monkey Equipment/Sanitation 12 06-24-2011 04:55 PM
Chugger Pump Review sjlammer Equipment/Sanitation 14 01-10-2011 01:32 PM
Chugger pump first time use problems Patirck Equipment/Sanitation 8 12-09-2010 11:51 PM
Cleaning a new Chugger Pump Cpt_Kirks Equipment/Sanitation 1 12-01-2010 04:21 PM
Chugger Pump Threads? Cpt_Kirks Equipment/Sanitation 3 10-28-2010 06:12 PM


Forum Jump