10 gal igloo malfunction - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > 10 gal igloo malfunction

Reply
 
Thread Tools
Old 01-31-2011, 02:41 AM   #1
skyebrewing
 
skyebrewing's Avatar
Recipes 
 
Aug 2010
Santa Cruz, Ca
Posts: 423
Liked 4 Times on 4 Posts



Today when i poured some 172' water in my igloo hlt, i started to hear some cracking. I looked in and found that from the bottom of the cooler, straight up, the inner lining had pulled away from the insulation about 1" wide and sticks out 3/4". This raised seam rises almost to the top. As it had not actually split open, i used it anyway. There was water in it for about 30 min and no loss in temp. When i added the water, the cooler was 55'. Its also only 2 months old and has only been used a couple of times.
Has this happened to anyone else?

 
Reply With Quote
Old 01-31-2011, 04:35 AM   #2
Mad_Milo
Recipes 
 
Mar 2009
Akron OH - Where the weak are killed and eaten.
Posts: 214
Liked 4 Times on 2 Posts


I've split an older, less worthy cooler over a number of brews. It has since been replaced by a 10g Igloo.

Sounds like you shocked it too hard. I usually warm it up some with a hot tap water spray just to get it used to the idea of going warm.

 
Reply With Quote
Old 01-31-2011, 02:34 PM   #3
DrawTap88
Recipes 
 
Jan 2010
Joliet, IL
Posts: 1,066
Liked 9 Times on 9 Posts


+1 to what Milo said. Gotta preheat these coolers if they've been sitting in the 20-40F garage.
__________________
Fermenting: Nothing
Secondary: Nothing
Bottled: Oatmeal Porter, Double Chocolate Chipotle Porter
Kegged: IPA, Red Rye

 
Reply With Quote
Old 02-06-2011, 02:47 AM   #4
skyebrewing
 
skyebrewing's Avatar
Recipes 
 
Aug 2010
Santa Cruz, Ca
Posts: 423
Liked 4 Times on 4 Posts


I added some warm tap water to my hlt while i was mashing to warm it up a bit. When i added my 170 water, no problems and no temp loss. I guess its just cosmetic..
__________________
Quote:
Originally Posted by nootay View Post
Its not terrible, but i get an armpit armoma and flavor.

 
Reply With Quote
Old 02-07-2011, 01:50 PM   #5
bja
Recipes 
 
Nov 2007
Pittsburgh
Posts: 2,059
Liked 167 Times on 125 Posts


Quote:
Originally Posted by skyewines View Post
Today when i poured some 172' water in my igloo hlt, i started to hear some cracking. I looked in and found that from the bottom of the cooler, straight up, the inner lining had pulled away from the insulation about 1" wide and sticks out 3/4". This raised seam rises almost to the top. As it had not actually split open, i used it anyway.
Mine did this the first time I used it. 2 years and 50 brews later it still works great.
__________________
____________________________________________

I know it just wouldn't be right to kill all the stupid people that we meet, but do you think it would be appropriate to just remove all of the warning labels and let nature take its course?

 
Reply With Quote
Old 02-07-2011, 04:58 PM   #6
Cpt_Kirks
 
Cpt_Kirks's Avatar
Recipes 
 
Sep 2008
Lakeland TN
Posts: 3,723
Liked 47 Times on 41 Posts


The first Igloo cooler I had did that, so I bought another one. It does it too. And, it did it first in the SUMMER, so I don't think a cold garage had anything to do with it.

The first MLT cooler flexed back and forth until it cracked along the high edge of the "hump" formed by the heat. The second has not cracked...YET.

So, even though coolers hold in the heat GREAT, I am dropping them for a very heavily insulated keggle MLT. Hopefully, the present cooler MLT will hold together long enough for me to finish the keggle one.


 
Reply With Quote
Old 02-08-2011, 03:14 AM   #7
skyebrewing
 
skyebrewing's Avatar
Recipes 
 
Aug 2010
Santa Cruz, Ca
Posts: 423
Liked 4 Times on 4 Posts


Thanks guys. Just glad to hear im not the only one. Still works and if i had to throw something away just because it looked funny, i'd be sitting in a trashcan right now

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rubbermaid vs. Igloo jacksonbrown Equipment/Sanitation 10 02-20-2014 01:08 PM
Manifold malfunction almost ruined my brew... badmajon Equipment/Sanitation 4 12-13-2010 04:50 PM
Regulator malfunction...is it shot? GLWIII Equipment/Sanitation 1 06-17-2010 03:00 PM
Temperature Probe Malfunction BierMuncher Equipment/Sanitation 16 10-17-2009 01:07 PM
Is this Igloo repairable? planenut Equipment/Sanitation 5 04-21-2009 02:31 AM


Forum Jump