Show us your element housings/pots. How did you do it? - Page 16 - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > Electric Brewing > Show us your element housings/pots. How did you do it?

Reply
 
Thread Tools
Old 10-31-2012, 08:42 PM   #151
Mb2658
Recipes 
 
Nov 2011
, NE
Posts: 419
Liked 36 Times on 26 Posts


Quote:
Originally Posted by ODI3

ah, Unfortunately my element is 1 1/4 in npt rather than the standard 1 in npt. The still dragon adapter wont work for me
Which element are you using?

 
Reply With Quote
Old 11-02-2012, 12:57 PM   #152
ODI3
Recipes 
 
Sep 2010
LONDON, Ontario Canada
Posts: 205
Liked 8 Times on 8 Posts


This one:
http://www.ebay.com/itm/200816740252...84.m1423.l2649

I am installing it in a 25 gal Megapot for biab.

 
Reply With Quote
Old 11-07-2012, 09:24 PM   #153
stamandster
Recipes 
 
Jun 2011
springfield, ma
Posts: 783
Liked 53 Times on 44 Posts


Nice find on the audiophile equipment for power! Now I can finally finish my build without breaking the bank.

 
Reply With Quote
Old 11-08-2012, 02:09 PM   #154
DustBow
 
DustBow's Avatar
Recipes 
 
May 2010
Cincy, OH
Posts: 634
Liked 21 Times on 19 Posts


I bought two sets of the "SwitchCraft" plugs & panel connectors off Amazon, they connect fine but don't seem to "lock" together likethey are supposed to....
__________________
"Brewers make wort, yeast make beer."

"Brewing beer is neither complicated nor expensive. It's the responsibility of the brewer to make it as complicated and expensive as their spouse & budget will allow."

 
Reply With Quote
Old 11-08-2012, 02:58 PM   #155
Yambor44
HBT_LIFETIMESUPPORTER.png
 
Yambor44's Avatar
Recipes 
 
Nov 2008
Ocala Florida
Posts: 2,108
Liked 84 Times on 56 Posts


Quote:
Originally Posted by DustBow View Post
I bought two sets of the "SwitchCraft" plugs & panel connectors off Amazon, they connect fine but don't seem to "lock" together likethey are supposed to....
I bought 2 sets directly from Mouser and they lock very well. Does your set have the metal peice on the "male" end? I can post pics later when I get home.

 
Reply With Quote
Old 11-08-2012, 03:00 PM   #156
runs4beer
Recipes 
 
Feb 2010
, NYC
Posts: 386
Liked 14 Times on 10 Posts


Quote:
Originally Posted by DustBow View Post
I bought two sets of the "SwitchCraft" plugs & panel connectors off Amazon, they connect fine but don't seem to "lock" together likethey are supposed to....
None of mine had a problem but I think JRems described the same/similar problem with one of his and was able to correct it with a metal file on the locking part…or something.
PM him and ask, it sounded like a quick fix it’s the same issue.
__________________
Never listen to electric guitar.
-DB
Some folks look for answers
Others look for fights
Some folks up in treetops
Just look to see the sights
-RH

 
Reply With Quote
Old 11-08-2012, 05:40 PM   #157
DustBow
 
DustBow's Avatar
Recipes 
 
May 2010
Cincy, OH
Posts: 634
Liked 21 Times on 19 Posts


OK, I haven't played around with it too much. The "male plugs" both have a metal strip that is supposed to lock into the panel mount, and I looked with a flashlight down into the "female panel" connection and you can see an area where the metal strip should latch into and "lock" into place. It just doesn't actually happen. Connection stilll feels pretty solid but it would make me feel better to hear and feel that "click" when the connection is really made/locked
__________________
"Brewers make wort, yeast make beer."

"Brewing beer is neither complicated nor expensive. It's the responsibility of the brewer to make it as complicated and expensive as their spouse & budget will allow."

 
Reply With Quote
Old 11-08-2012, 06:49 PM   #158
Yambor44
HBT_LIFETIMESUPPORTER.png
 
Yambor44's Avatar
Recipes 
 
Nov 2008
Ocala Florida
Posts: 2,108
Liked 84 Times on 56 Posts


Quote:
Originally Posted by DustBow View Post
OK, I haven't played around with it too much. The "male plugs" both have a metal strip that is supposed to lock into the panel mount, and I looked with a flashlight down into the "female panel" connection and you can see an area where the metal strip should latch into and "lock" into place. It just doesn't actually happen. Connection stilll feels pretty solid but it would make me feel better to hear and feel that "click" when the connection is really made/locked
I'm sure you've already done this, but it did that a time or three with me. Once I pressed a little harder and got it to snap, it does it no problem each time now.

 
Reply With Quote
Old 11-08-2012, 07:29 PM   #159
DustBow
 
DustBow's Avatar
Recipes 
 
May 2010
Cincy, OH
Posts: 634
Liked 21 Times on 19 Posts


Yeah, mine almost seem opposite - thought they locked when they first arrived, then when I was fooling around with them the other day, I couldn't get them to click.
__________________
"Brewers make wort, yeast make beer."

"Brewing beer is neither complicated nor expensive. It's the responsibility of the brewer to make it as complicated and expensive as their spouse & budget will allow."

 
Reply With Quote
Old 02-04-2013, 02:17 PM   #160
Alefebvre
Recipes 
 
Mar 2011
Ottawa, ON
Posts: 27

Seems this thread has been dead for a while but I thought I'd post my recent setup since I know what it's like to want actual pictures of setups. Got the idea from post #6 on this thread.
Click image for larger version

Name:	photo 1.jpg
Views:	1549
Size:	31.6 KB
ID:	98778   Click image for larger version

Name:	photo 2.jpg
Views:	1565
Size:	48.4 KB
ID:	98779   Click image for larger version

Name:	photo 3.jpg
Views:	1573
Size:	45.3 KB
ID:	98780   Click image for larger version

Name:	photo 4.jpg
Views:	1568
Size:	23.7 KB
ID:	98781  

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
What does your element look like? dboblitt Electric Brewing 4 01-10-2012 04:08 PM
Element Install in a 1/2 Keg LiverDance Electric Brewing 7 12-05-2010 05:36 PM
208 volt element Budzu Electric Brewing 14 11-06-2010 02:19 AM
Where did you get your heating element? CircleC-Brewer Electric Brewing 20 10-29-2010 02:26 PM
Did I just ruin my element? dboblitt Electric Brewing 3 10-11-2010 06:02 PM


Forum Jump