Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > Pumping Oxyclean through March Pump
Reply
 
Thread Tools
Old 04-26-2010, 03:59 PM   #1
jjyoung
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2010
Location: Massachusetts
Posts: 48
Default Pumping Oxyclean through March Pump

I tried my pilot run using my new Counter Top Brutus rig and ran into a problem. When I tried running Oxyclean through it the March pump wouldn't circulate it properly. It appears that it foamed up in the pump and the resulting foam was dense enough not to allow the pump to fill with fluid, and the foam wasn't dense enough to actually pump. I actually had to take the pump head off to clear it. Has anyone else had this kind of problem, and were you able to correct it without disconnecting hoses?
jjyoung is offline
 
Reply With Quote
Old 04-26-2010, 05:29 PM   #2
jkarp
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2008
Location: Elizabeth, CO
Posts: 2,106
Liked 37 Times on 31 Posts
Likes Given: 4

Default

Huh, I've never had a problem with oxy foaming or priming through the pump. What about getting it running with just water and then adding the oxy?
jkarp is offline
 
Reply With Quote
Old 04-26-2010, 05:37 PM   #3
Irrenarzt
HNIC
HBT_LIFETIMESUPPORTER.png
Feedback Score: 3 reviews
 
Irrenarzt's Avatar
Recipes 
 
Join Date: Aug 2009
Location: Half a mile from Tucson
Posts: 1,918
Liked 160 Times on 116 Posts
Likes Given: 92

Default

sound like a priming issue. You need to suck those bubbles out of the head. Sounds ghey I know but that'll fix it right up.
Irrenarzt is offline
 
Reply With Quote
Old 04-26-2010, 05:38 PM   #4
Catt22
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Posts: 5,000
Liked 62 Times on 59 Posts
Likes Given: 51

Default

Nope. I circulate a hot water + Oxyclean with my pump regularly and have had no problems with priming or foaming. I do have an air bleed valve installed which makes priming a no brainer. Unless you have an air leak somewhere, there shouldn't be any foaming in the pump or lines.
Catt22 is offline
 
Reply With Quote
Old 04-26-2010, 05:45 PM   #5
Irrenarzt
HNIC
HBT_LIFETIMESUPPORTER.png
Feedback Score: 3 reviews
 
Irrenarzt's Avatar
Recipes 
 
Join Date: Aug 2009
Location: Half a mile from Tucson
Posts: 1,918
Liked 160 Times on 116 Posts
Likes Given: 92

Default

Post up a pic of your bleeding arrangement. I need to do something and need ideas on how to go about it. Thanks.
Irrenarzt is offline
 
Reply With Quote
Old 04-26-2010, 05:48 PM   #6
jjyoung
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2010
Location: Massachusetts
Posts: 48
Default

Irrenarzt said:
Quote:
sound like a priming issue
I agree that it's a priming issue. I tried lowering the pump to get more pressure to the head but it didn't work.

jkarp said:
Quote:
What about getting it running with just water and then adding the oxy?
Yeah, I'll give that a try. I initially thought that I had a tubing crimp in my chiller and I ended up pulling the pump out of the bucket and using another chiller that I had. I'll need to take a closer look at the chiller to see if it's crimped or if I was initially having the foaming problem. When you start the pump with Oxy do you have the valve on the output wide open? I originally didn't do that and am wondering if the foam was created in the pump due to the pump churning the Oxy solution. I cleared the pump head once and turned the pump on without having the outlet valve all the way open and it happened again.

jjyoung is offline
 
Reply With Quote
Old 04-26-2010, 06:18 PM   #7
Catt22
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Posts: 5,000
Liked 62 Times on 59 Posts
Likes Given: 51

Default

Quote:
Originally Posted by Irrenarzt View Post
Post up a pic of your bleeding arrangement. I need to do something and need ideas on how to go about it. Thanks.
Here ya go:



You can see the bleed valve behind the gate valve with the green handle. It's just a 1/4" ball valve with a NPT x Barb elbow attached. The bleed valve is also handy for grabbing wort samples when using the pump on my RIMS. The dial is a vacuum gauge I use to monitor the suction applied to the mash tun outlet.
Catt22 is offline
 
Reply With Quote
Reply


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why won't my March pump march? wildwest450 Equipment/Sanitation 12 10-09-2011 04:01 PM
Dual purpose March Pump as a Rain Barrel Pump nanotigerbrewer Equipment/Sanitation 6 12-01-2010 07:18 PM
How high can a March Pump--pump? jlosbor Equipment/Sanitation 18 07-02-2010 03:13 PM
Sold - March Pump w/brass pump head SSRider For Sale 15 02-02-2010 08:15 PM
March Pump Set Up Gammon N Beer Equipment/Sanitation 4 05-28-2009 08:03 PM


Forum Jump

Newest Threads

LATEST SPONSOR DEALS