Small Outboard Motors - Home Brew Forums
Register Now For Free!

Home Brew Forums > Home Brewing Community > General Chit Chat > Small Outboard Motors

Reply
 
Thread Tools
Old 04-12-2010, 08:00 PM   #1
Fletch78
 
Fletch78's Avatar
Recipes 
 
Feb 2010
Athens GA
Posts: 1,345
Liked 26 Times on 18 Posts



Does anyone here know jack **** about small outboard motors? Specifically, a 7.5 Sears Gamefisher from the early 90's.

olllllo Likes This 
Reply With Quote
Old 04-13-2010, 11:19 AM   #2
Homercidal
Licensed Sensual Massage Therapist.
HBT_MODERATOR.png
 
Homercidal's Avatar
Recipes 
 
Feb 2008
Reed City, MI
Posts: 31,417
Liked 5022 Times on 3391 Posts


What's the matter with it?
__________________
Day after day, it reappears. Night after night my heartbeat shows the fear. Ghosts appear and fade away. Come back another day.

 
Reply With Quote
Old 04-13-2010, 02:21 PM   #3
jeff967
Recipes 
 
Aug 2007
Swartz,La.
Posts: 144

What's the matter with it?
+2

 
Reply With Quote
Old 04-13-2010, 02:30 PM   #4
GilaMinumBeer
Half-fast Prattlarian
HBT_LIFETIMESUPPORTER.png
 
GilaMinumBeer's Avatar
Recipes 
 
Jan 2008
Posts: 59,283
Liked 7720 Times on 6301 Posts


It's likely a re-labeled johnson.

 
Reply With Quote
Old 04-14-2010, 02:03 AM   #5
GreenMonti
HBT_SUPPORTER.png
Recipes 
 
Nov 2009
Posts: 1,162
Liked 23 Times on 20 Posts


I have a 3 HP game fisher. I am gonna take a wild stab and tell you to open the vent in the center of the gas cap.

 
Reply With Quote
Old 04-14-2010, 12:24 PM   #6
Fletch78
 
Fletch78's Avatar
Recipes 
 
Feb 2010
Athens GA
Posts: 1,345
Liked 26 Times on 18 Posts


Dirty jets, and possibly a bad impleller. I won't know until I can get it running. I have to steal some metric wrenches from work today in order to remove the carb and soak it. I "assisted" my father 10 years ago doing this on the same motor. This is going to suck.

I already replaced fuel hose and got new gas. And the vent isn't an issue since I realized there's a crack in the tank anyway (at the top, no dripping leaks, just vapor leak).... that will also have to be replaced.

 
Reply With Quote
Old 04-14-2010, 01:22 PM   #7
GilaMinumBeer
Half-fast Prattlarian
HBT_LIFETIMESUPPORTER.png
 
GilaMinumBeer's Avatar
Recipes 
 
Jan 2008
Posts: 59,283
Liked 7720 Times on 6301 Posts


Ha. Been there done that.

1973 75 horse Evinrude Triumph 3 Cyl. $400 spent to rebuild it. Carb kits, lines, impeller, this, that.

Never could get that b!tch to run. It was given to me so I sold it for $500.

 
Reply With Quote
Old 04-14-2010, 11:15 PM   #8
GreenMonti
HBT_SUPPORTER.png
Recipes 
 
Nov 2009
Posts: 1,162
Liked 23 Times on 20 Posts


Quote:
Originally Posted by Fletch78 View Post
Dirty jets, and possibly a bad impleller. I won't know until I can get it running. I have to steal some metric wrenches from work today in order to remove the carb and soak it. I "assisted" my father 10 years ago doing this on the same motor. This is going to suck.

I already replaced fuel hose and got new gas. And the vent isn't an issue since I realized there's a crack in the tank anyway (at the top, no dripping leaks, just vapor leak).... that will also have to be replaced.

Mine was given to me by an old neighbor. He told me it was seized. I will give him some credit as it was locked up. Some gental presuasion and some penetrating lube, and I had it un-seized. It runs like a champ. I bought some parts for it from sears. I was kinda shocked that they would still have parts for it. Very cheap and they came right in the mail. They even sent me a copy of the owners manual.

Is yours air cooled? Mine is a 2 stroke air cooled motor.

Now, I am just asking. You have checked the basics right? Got spark, good plug? Does it sputter like it wants to run?

 
Reply With Quote
Old 04-15-2010, 01:36 AM   #9
Fletch78
 
Fletch78's Avatar
Recipes 
 
Feb 2010
Athens GA
Posts: 1,345
Liked 26 Times on 18 Posts


Starts with gas/oil spritz from water bottle but won't run. Gas is getting to the carb, i loosened the hose clamp and gas pumps out when I pump the bulb but won't flood. Classic clogged jets according to internet. So I assume fuel filter/pumpdiaphram is working-not blocked. Impeller- After many starts but no running, I noticed bone dry pee-hole. So that's another problem. After sitting there for over a year, I guess it may have just dried out. I really don't know. But I can't verify it's bad until it runs, and by running it I am doing irreparable damage if the impeller (water pump) doesn't work.

I didn't steal my wrenches today, but I did set them aside...

 
Reply With Quote
Old 04-15-2010, 05:01 PM   #10
Homercidal
Licensed Sensual Massage Therapist.
HBT_MODERATOR.png
 
Homercidal's Avatar
Recipes 
 
Feb 2008
Reed City, MI
Posts: 31,417
Liked 5022 Times on 3391 Posts


I'd tear into the impeller and find out for sure. You sure don't want to run it for more than a couple of seconds without the water pumping through it.
__________________
Day after day, it reappears. Night after night my heartbeat shows the fear. Ghosts appear and fade away. Come back another day.

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electric motors and stirring/cooling wort Dubcut Equipment/Sanitation 17 07-31-2010 06:55 PM
Electric Trolling Motors? RIBeer General Chit Chat 6 04-12-2010 08:05 PM
motor city motors friarjohn General Chit Chat 0 03-22-2010 06:06 PM
using open small fridge to cool small insulated closet? Budzu Fermenters 16 03-18-2009 10:05 PM
Found a Cheap Place For HLT/Mash Mix Motors, Temp Control, Peltier, & More fifelee Equipment/Sanitation 0 11-01-2008 03:18 AM


Forum Jump