????'s - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > Extract Brewing > ????'s

Thread Tools
Old 02-07-2010, 05:29 AM   #1
cd38's Avatar
Feb 2009
Posts: 216
Liked 3 Times on 2 Posts

Alright so today I brewed my AHS American IPA extract kit. I just got a new pot so I was ready to get it work. Everything went pretty okey till I dropped my spoon in the wort, I did sanitize a pair of tongs to get it out in a decent amount of time. When pouing this IPA into my carboy it foamed out like if I would have poured too much beer in a glass, is this normal? Also my gravity was high, the recipe called for 1.050-1.052 mine was 1.060, any particular reason why? My temp got a lil high on steeping got to almost 175 and I also scorched some some of the LME would this have anything to do with the OG being high? Thanks for all the replies.

Reply With Quote
Old 02-07-2010, 05:38 AM   #2
Tripod's Avatar
Sep 2008
Atlanta, GA
Posts: 642
Liked 7 Times on 7 Posts

High gravity was most likely a wort not mixed well with water added after the boil...but impossible to predict. Could you post your methods and recipe?
No trees were harmed in the posting of this message but a large number of electrons were terribly inconvenienced...

Primary: First AG Batch! - Irish Red | Bottle: Oatmeal Stout| Drinking: Nearcastle II... | Up Next: It may be time to try a lager


Reply With Quote
Old 02-11-2010, 11:40 PM   #3
Apendecto's Avatar
Jul 2009
Rockwood, MI
Posts: 457
Liked 9 Times on 6 Posts

Sounds like all sorts of stuff went wrong. What's the update?

Reply With Quote
Thread Tools

Forum Jump