Coldbreak Brewing HERMS Giveaway!

HomeBrewSupply AMCYL Brew Kettle Giveaway!


Home Brew Forums > Home Brewing Beer > Extract Brewing > ????'s
Reply
 
Thread Tools
Old 02-07-2010, 05:29 AM   #1
cd38
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2009
Location: Dallas,Texas
Posts: 218
Liked 3 Times on 2 Posts
Likes Given: 6

Default ????'s

Alright so today I brewed my AHS American IPA extract kit. I just got a new pot so I was ready to get it work. Everything went pretty okey till I dropped my spoon in the wort, I did sanitize a pair of tongs to get it out in a decent amount of time. When pouing this IPA into my carboy it foamed out like if I would have poured too much beer in a glass, is this normal? Also my gravity was high, the recipe called for 1.050-1.052 mine was 1.060, any particular reason why? My temp got a lil high on steeping got to almost 175 and I also scorched some some of the LME would this have anything to do with the OG being high? Thanks for all the replies.


cd38 is offline
 
Reply With Quote
Old 02-07-2010, 05:38 AM   #2
Tripod
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2008
Location: Atlanta, GA
Posts: 661
Liked 7 Times on 7 Posts

Default

High gravity was most likely a wort not mixed well with water added after the boil...but impossible to predict. Could you post your methods and recipe?
__________________
No trees were harmed in the posting of this message but a large number of electrons were terribly inconvenienced...

Primary: First AG Batch! - Irish Red | Bottle: Oatmeal Stout| Drinking: Nearcastle II... | Up Next: It may be time to try a lager

5/2012
Tripod is offline
 
Reply With Quote
Old 02-11-2010, 11:40 PM   #3
Apendecto
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jul 2009
Location: Rockwood, MI
Posts: 458
Liked 9 Times on 6 Posts
Likes Given: 19

Default

Sounds like all sorts of stuff went wrong. What's the update?
Apendecto is offline
 
Reply With Quote
Reply


Thread Tools



Forum Jump

Newest Threads

LATEST SPONSOR DEALS