I think I have a problem - Home Brew Forums
Home Brew Forums > Home Brewing Beer > Beginners Beer Brewing Forum > I think I have a problem
Cool Brewing Giveaway - Supporting Membership Drive & Discount

Reply
 
Thread Tools
Old 10-08-2009, 04:50 PM   #1
wildeagles87
Recipes 
 
Oct 2009
Emeryville, CA
Posts: 23


I just brewed my third batch of beer. My first tasted great, but my second had a funny clove like taste. My third beer has been in the fermenter for a week the OG was 1.065 and the reading I got today was 1.025. It also has the clove like smell to it. I don't know what I did wrong. I cleaned and sanitized everything with iodophor. I don't know if i should transfer to secondary yet or let sit for another week. It is a pumpkin ale and I was really excited about it. Please help.



 
Reply With Quote
Old 10-08-2009, 04:59 PM   #2
android
Recipes 
 
Jan 2009
Ames, Iowa
Posts: 3,060
Liked 42 Times on 33 Posts


what kind of yeast did you use and what temps has it been at during fermentation (for beers 2 and 3)? i'd let it keep going in the primary at least until you get to your anticipated FG. any kind of spices in your pumpkin ale?


__________________
primary: APA

ebay temp controller | thermostat temp controller

 
Reply With Quote
Old 10-08-2009, 05:10 PM   #3
wildeagles87
Recipes 
 
Oct 2009
Emeryville, CA
Posts: 23

I used Danstar Windsor Ale. The temp of fermentation has been around 70 degrees for this ale. It had cinnamon, sweet orange peel, mace, allspice, nutmeg, and ginger for spices. The last beer the temp was higher closer to 75 or 80 because it was very hot here. And the first beer had a similar temp. I read that maybe the reason it has this is because i did not let the iodophor solution dry or rinse it out before adding the wort. maybe the iodine caused this. In which case i messed up and obviously have a lot to learn.

 
Reply With Quote
Old 10-08-2009, 05:29 PM   #4
corvax13
Recipes 
 
Jul 2009
Savannah, GA, US
Posts: 294
Liked 1 Times on 1 Posts


I'm going to guess your temperatures were a little high - 75 or 80 is too hot, and saying "around 70 degree" leads to me believe you are not entirely sure. How are you keeping track of the temperature?

Also, ambient temperature does not reflect fermentation temperature. There is a vicious battle going on in there, between yeasts and the sugars, and this battle will produce a lot of heat. If you ambient temperature was "around 70", chances are your fermentation temp was around more than 70 - probably 75 or so, which is on the warm side.

I would let it sit on the primary for a couple more weeks. They flavor may mellow out, or it may not. I know this because I have a brown ale that suffered the same high temperatures (brewing in southern georgia summer heat is brutal), and they have been in the bottles for 7-8 weeks, the flavor is still there... decreasing very very slowly, but still there (not sure if it will ever fade completely....)

Good luck!
__________________
Furry Friend Brewery

 
Reply With Quote
Old 10-08-2009, 05:32 PM   #5
david_42
 
david_42's Avatar
Recipes 
 
Oct 2005
Willamina & Oak Grove, Oregon, USA
Posts: 25,576
Liked 148 Times on 139 Posts


Windsor is a low attenuation yeast and pumpkin ales (if you used pumpkin) can have a lot of non-fermentables. Clove shouldn't be a problem in a pumpkin ale, although how you can smell it through the allspice is a question.
__________________
Remember one unassailable statistic, as explained by the late, great George Carlin: "Just think of how stupid the average person is, and then realize half of them are even stupider!"

"I would like to die on Mars, just not on impact." Elon Musk

 
Reply With Quote
Old 10-08-2009, 05:52 PM   #6
shortyjacobs
Recipes 
 
Aug 2009
Twin Cities, MN
Posts: 2,507
Liked 33 Times on 33 Posts


Iodophor is a NO-RINSE solution. You aren't supposed to rinse it out, and if you rinse it with un-sanitized water, you just un-did all the sanitizing done by the iodophor. The iodine will not cause issues.

If I understand right, you are worried about a clove smell coming from a beer that you added orange, mace, allspice,nutmeg, and ginger to?? Seems like it SHOULD smell something like cloves.

Your second beer probably tasted fruity because of the high fermentation temps.

Don't worry about your SG being only 1.025...you've only had it in the fermenter for a week.

Leave it in the fermenter for two weeks more, then test the SG, make sure it's OK, then bottle it. Your beer is probably fine.

Again, Iodophor is GOOD, don't let it dry, don't rinse it out, when it's wet it means the surface is sanitized....

 
Reply With Quote
Old 10-08-2009, 05:59 PM   #7
wildeagles87
Recipes 
 
Oct 2009
Emeryville, CA
Posts: 23

Thanks for all the help. I will just see how it turns out down the road. This is all still new for me and I appreciate your input.

 
Reply With Quote
Old 10-08-2009, 06:05 PM   #8
FireNightFly
Recipes 
 
Aug 2009
Ohio
Posts: 731
Liked 1 Times on 1 Posts


RDWHAHB


__________________
Variety is the spice of life.

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
This is how you know you have a problem Noleafclover Fermentation & Yeast 3 10-08-2009 12:32 PM
Got a problem svengoat Hops Growing 1 05-08-2009 06:02 AM
Is there a problem Brutus Brewer Extract Brewing 6 08-03-2006 07:24 AM


Forum Jump