Trouble? - Home Brew Forums

Register Now!
Home Brew Forums > Home Brewing Beer > General Techniques > Trouble?

Reply
 
Thread Tools
Old 09-28-2009, 02:28 PM   #1
Milesteg
Recipes 
 
Sep 2009
Upstate NY
Posts: 5


I'm on about my 12th extract brew and am massing my gear for all grain. Im currently using a bucket for my primary and a carboy for my secondary. With the last two brews after I have re-racked to the secondary there has been a strange white film on the top of it. At first I thought that it might have been the sun light because of the season change I hadn't noticed that the sun was hitting it in the morning. Then I figured the light couldn't have been that much of a factor and it must have been my sanitation procedures. I found out that I was using a cleanser and not a sanitizer. I bought an iodine based sanitizer and have been using that . Now with my current brew the same thing happened in the secondary but worse now it looks like there's a layer of white mold on the top. I have a couple of questions do you think that it really is mold and if it is, is it even worth bottling? Secondly what can I do to prevent this in the future? I want to have a solid procedure before I go to all grain. Any tips or thoughts would be a big help thanks!

 
Reply With Quote
Reply
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Am I asking for trouble? spacebarcowboy Bottling/Kegging 2 11-17-2008 09:41 PM
I may be in big trouble? ChilliBrew Extract Brewing 6 02-15-2007 10:48 PM
Am In in trouble? bare19672 Beginners Beer Brewing Forum 4 01-24-2007 07:40 PM
HELP! am I in trouble? kfgolfer Bottling/Kegging 13 01-05-2007 02:28 AM


Forum Jump