WalterAtMarchPump

Gift Premium Subscription To WalterAtMarchPump

Join Date:

12-01-2010

Last Activity:

07-29-2015 9:01 PM

Likes Given: 12

45 Likes on 35 Posts 

    ABOUT ME

  • Engineer
  • Walter
  • Male
  • Married
  • Glenview
  • IL

LATEST ACTIVITY

  • Posted in thread: Questions about March Pumps answered by the Factory! on 07-29-2015 at 01:55 PM
    No nothing out of the ordinary here....phones are working just fine....i have had issues from
    the east coast before though....its weird...i've tried calling our regional sales manager a few
    times and ...

  • Posted in thread: Questions about March Pumps answered by the Factory! on 07-28-2015 at 08:58 PM
    Wayne must be stressin out as of late.....may be the blue moon coming this friday.....if he
    gives you any lip about returning it to the distributor or such just send it back here to my
    attention. ;)

  • Posted in thread: Questions about March Pumps answered by the Factory! on 07-28-2015 at 05:17 PM
    call the factory direct at 847-729-5300 and ask for Wayne :)

  • Posted in thread: Questions about March Pumps answered by the Factory! on 07-28-2015 at 02:49 PM
    Sorry guys....i'm not sure why i don't get any notifications on new postings
    anymore...Stealthcruiser......the serial number tells me when it was built (month/year) but
    that's not necessarily what we ...

  • Posted in thread: Questions about March Pumps answered by the Factory! on 07-07-2015 at 02:11 PM
    Hi Walter,I'm in the process of building a large Brutus like system and saw the H325 pump in a
    recent Morebeer catalog. Can you set me up with a part number for an H325 with the largest
    impeller you h...

  • Posted in thread: Questions about March Pumps answered by the Factory! on 07-07-2015 at 02:08 PM
    Pump question, Walter:Pump has approx. 40-50 hours on it, I would guesstimate.The motor began
    to act like a motor, that had a capacitor going bad, ( does it have one?), in that it would hum
    and slowly...

  • Posted in thread: Pump shaft and flange misalignment on 06-15-2015 at 02:27 PM
    Are you removing the motor bracket to mount this stuff up? If so you are probably messing up
    the alignment of the drive magnet in relation to the pump housing. We use a jig here at the
    factory to cent...

  • Posted in thread: Does anyone else hate their Chugger pumps? on 06-12-2015 at 03:52 PM
    I'll third the bleeder valve recommendation. My March pumps used to give me fits as well until
    I installed one.To tell you the truth, I'm not sure if they aren't both the same pump off the
    same line w...

  • Posted in thread: March Pump customer support on 06-12-2015 at 03:34 PM
    Actually his motor was damaged...either was accidentally dropped or something fell on it. Wayne
    happened to have a good one in the parts dept and swapped it out. We try and help the
    homebrewers out as...

  • Posted in thread: March 815 Pump Repair Help on 03-23-2015 at 01:33 PM
    Im only guessing without seeing it and there's not much info to go on....but my (GUESS) would
    be the motors tweaked. Take the pump head off and try running it.....if it runs no problem then
    your pump ...

FORUM SIGNATURE
-Walter
0 COMMENTS
POST A COMMENT

Newest Threads

LATEST SPONSOR DEALS