VIEW MY

Triple9

Gift Premium Subscription To Triple9

Join Date:

03-19-2011

Last Activity:

02-25-2015 7:12 PM

1 Likes on 1 Posts 

    ABOUT ME

  • Single
  • Melrose
  • MA

LATEST ACTIVITY

  • Posted in thread: Heating Elements with Aluminum Pots on 10-24-2013 at 08:01 PM
    I've done about 20 batches with an aluminum pot and 5500W element. No problems whatsoever.
    Hardest part is threading the nut on the element as aluminum pots are thicker than SS, so can
    sometimes take ...

  • Posted in thread: An IPA Experiment. Thoughts? on 10-23-2013 at 05:22 PM
    Here's the setup. I have an IPA going into the Keg on Friday on Nottingham as well as a
    Belgian-ish Strong Ale on T-58. I have a ton of hops in the freezer I've been trying to work my
    way through, so ...

  • Posted in thread: Edworts Haus Oops on 02-06-2013 at 09:01 PM
    Was brewing the Haus pale last night and hit all my numbers perfectly. Then threw the container
    with an ounce of Amarillo and half ounce of simcoe in the kettle when the boil started, Whoops,
    those we...

  • Posted in thread: Houston...we almost had a big problem on 11-18-2012 at 07:37 PM
    I did use the strip gauge. It's char.

  • Posted in thread: Houston...we almost had a big problem on 11-18-2012 at 02:52 PM
    In hindsight, I think installing the receptacles in the panel and then installing the wires
    might have contributed to the problem. Smaller space to really torque everything down well.
    This may be a go...

  • Posted in thread: Houston...we almost had a big problem on 11-18-2012 at 02:51 AM
    Ok, dismantled it and here's what we have. I do believe i will switch to solid core when I put
    the new receptacle in. Thanks for the heads up. I have a ton of it lying around, so should be
    an easy fix...

  • Posted in thread: Houston...we almost had a big problem on 11-17-2012 at 11:35 PM
    No worries. Probably be a day or two before I pull it apart and take some shots.

  • Posted in thread: Houston...we almost had a big problem on 11-17-2012 at 08:55 PM
    Yeah, not the greatest feeling thinking about what could have happened. It was one of the hot
    wires and right at the receptacle, so no crimp. Screwed down.

  • Posted in thread: Houston...we almost had a big problem on 11-17-2012 at 07:57 PM
    Started heating my HLT up today and went upstairs while the water was heating. Went to check on
    it about 15 minutes later and noticed the smell of plastic in the air. Shut everything down,
    opened up t...

  • Posted in thread: New England Group Buy round 2 on 03-29-2012 at 09:41 PM
    That works for me. If you could pm me your PayPal, I'll get payment out in the morning.

0 COMMENTS
POST A COMMENT

Newest Threads