VIEW MY

ToddPEI

Gift Premium Subscription To ToddPEI

Join Date:

03-31-2012

Last Activity:

10-22-2014 4:17 PM

Likes Given: 1

2 Likes on 2 Posts 

    ABOUT ME

  • M.Sc. Student
  • In a Relationship
  • London
  • Ontario

LATEST ACTIVITY

  • Posted in thread: Infected glass carboys on 08-14-2014 at 09:15 PM
    Thanks, I just bought new plastics, and as I mentioned new yeast. Hopefully the next batch
    turns out well. Happy and successful brewing to you all!

  • Posted in thread: Infected glass carboys on 08-14-2014 at 08:27 PM
    The last couple batches i've had to toss down the drain due to infection.I've tried soaking
    them in bleach, then rinsing, then soaking with Oxyclean, rinse and finally StarSan. And again
    i've had issu...

  • Posted in thread: EC20 Request on 01-23-2014 at 11:17 AM
    @badlee: Yeah, it is great to have a supportive and great community.@Soilworker: Thanks, now I
    can keep my eyes open for future ECY sales, and not worry about border nonsense.

  • Posted in thread: Man, I love Apfelwein on 01-21-2014 at 10:22 PM
    WOW!I brewed this up Jan 2013, and got lazy and didn't want to bottle it, so I forgot about it
    for a while. I recently found it and kegged it up last week (Jan 2014). AMAZING! I'd drink this
    over many...

  • Posted in thread: EC20 Request on 01-21-2014 at 03:19 PM
    I've been itching to buy some EC20 from love2brew.com. Unfortunately, I live in Canada, and
    they don't ship here. I was going to get it shipped to the border and pick it up by the ferry
    (close to wher...

  • Posted in thread: Oud Bruin Fermentation on 12-10-2013 at 02:35 AM
    I was listening to the Jamil show, and he mentions leaving it in the carboy for only 1 month, I
    figured it would pick up more character in the keg. But, if the consensus is to leave it in the
    carboy f...

  • Posted in thread: Oud Bruin Fermentation on 12-06-2013 at 04:18 PM
    I'm currently fermenting an Oud Bruin using Jamil's recipe from CYBI.I'm wondering, is it
    necessary to transfer off the primary yeast (I used US-05), before adding my Roselair blend? Or
    can I keep the...

  • Posted in thread: Flashing STC-1000 on 11-23-2013 at 03:26 AM
    Looks like my sensor probe was the issue. I detached the wires, and reattached them, and the
    unit seems to be working perfectly now. I'm letting it go overnight, and I'll see how it is in
    the morning.

  • Posted in thread: Flashing STC-1000 on 11-21-2013 at 02:07 AM
    I just tried that, and it worked for a while. But, the light isn't on anymore, and the stc is
    flashing again.

  • Posted in thread: Flashing STC-1000 on 11-21-2013 at 01:14 AM
    A friend made me an STC-1000 to help control the temperature of a freezer. It was working fine
    for a couple of weeks. But when I got home today, my freezer wasn't cooling (I tested the
    freezer and plu...

0 COMMENTS
POST A COMMENT

Newest Threads

PHOTO OF THE DAY