VIEW MY

tankmech

Gift Premium Subscription To tankmech

Join Date:

10-10-2013

Last Activity:

04-19-2014 6:33 AM

5 Likes on 4 Posts 

LATEST ACTIVITY

  • Posted in thread: Homebrew For Heroes in the News on 01-27-2014 at 01:17 AM
    I have a question. How can I get involved with this. I am a post commander of a vfw in almena,
    wi. I would love to find a way to help. Please let me know what I can do. I have been brewing
    beer since ...

  • Posted in thread: Airlock Lopsided on 01-20-2014 at 01:41 AM
    It should be fine. My three price airlock on my weizenbeir is the same way. Don't worry.

  • Posted in thread: How many gallons of homebrew in 2014? on 01-20-2014 at 01:26 AM
    +5 gal Black IPA= 1804.5 gallons+ 5 gallons weizenbeir, + 5 gallons American cream ale= 1814.5
    gallons

  • Posted in thread: So who's brewing this weekend? on 01-18-2014 at 07:30 PM
    Hopefully I will get to brewing a American cream ale.

  • Posted in thread: Did I Kill My Yeast? on 01-17-2014 at 09:40 PM
    I had a beer that kicked in on the fifth day, that is when it actually started to ferment. It
    was a weizen. So don't worry have a home brew.

  • Posted in thread: Ok been over 72 hours and no signs of fermenting starting on 01-16-2014 at 09:13 PM
    Just a update, finally my beer has started to ferment. Hopefully it turns out good tasting.
    Thank you all for your advice.

  • Posted in thread: Ok been over 72 hours and no signs of fermenting starting on 01-16-2014 at 12:05 AM
    I don't remember the date on the package. Did the same I always do when brewing. So I am
    stumped also. So hopefully come Friday when I can get to my home brew store the wort will still
    be good.

  • Posted in thread: Ok been over 72 hours and no signs of fermenting starting on 01-15-2014 at 11:41 PM
    Yea gave it done good shakes, like I always do. I will give it till Friday after work, if still
    nothing I will run to my lhbs and pick up some yeast. Then re pitch it.

  • Posted in thread: Ok been over 72 hours and no signs of fermenting starting on 01-15-2014 at 11:25 PM
    The instructions came of the danistar Web site. It was a 5 gal extract kit from brewers best.
    Og started at 1.046. For days later it is the same. Won't be able to get to my lhbs till Friday
    to pick up...

  • Posted in thread: Ok been over 72 hours and no signs of fermenting starting on 01-15-2014 at 10:50 PM
    It was a dry Munich yeast. That came with the kit. Followed instructions on line about getting
    the dry yeast going. Pitch temp was I believe 76. Don't have my notes with me downstairs.

0 COMMENTS
POST A COMMENT