VIEW MY

squidbait

Gift Premium Subscription To squidbait

Join Date:

02-06-2010

Last Activity:

01-05-2014 2:46 PM

    ABOUT ME

  • Detroit Area
  • Single

LATEST ACTIVITY

  • Posted in thread: SWMBO Flavor Translator Needed on 07-06-2013 at 01:03 AM
    Thought I would share a story and thoughts from tonight....I was out to dinner tonight with
    SWMBO having a local craft beer that she was enjoying. I asked what she liked about it compared
    to what I cu...

  • Posted in thread: Another "unbalanced" report / question on 04-06-2013 at 12:26 AM
    Ok, thanks for the response. Maybe I will eventually get a third party report as well. Any
    metro Detroiters out there have any other tips?

  • Posted in thread: Another "unbalanced" report / question on 04-04-2013 at 11:50 PM
    Should I not trust this report considering the report shows .69 for the ion balance? I was
    looking forward to stepping up by brews with some water work, but am stuck. Any help is much
    appreciated!

  • Posted in thread: Chugger Pump, First run smell on 03-31-2013 at 01:52 PM
    Don't forget, the motor should be oiled yearly with 4-5 drops SAE20 weight non-detergent oil.I
    see the arrow where is says to add oil, but I don't see actually where it goes. Any info on how
    to apply ...

  • Posted in thread: Chugger Pump, First run smell on 03-31-2013 at 02:54 AM
    Yep, brewed today, no smell. Thanks everyone.

  • Posted in thread: Chugger Pump, First run smell on 03-30-2013 at 01:06 AM
    Thanks for the reply. I also figured it was residuals oils or whatever, but surprised there
    weren't any posts about it. I will continue to monitor it.

  • Posted in thread: Chugger Pump, First run smell on 03-29-2013 at 10:47 PM
    I ran my new Chugger pump for the first time today. Everything appears to be running well, but
    the pump is emitting a fairly strong smell. It is almost a burnt type of smell, and the pump is
    fairly ho...

  • Posted in thread: Ground Position, Please verify on 03-29-2013 at 04:22 PM
    How do you intend to ground it? Drilling a hole into it, or soldering or...? Either way, if
    there's no connection between the element and the kettle / back box, you're going to want to
    bond all of the...

  • Posted in thread: 110v Recirculating eBIAB 2.5 gallon batches on 03-29-2013 at 04:52 AM
    Jr,I finally got it figured out. I am awful with electrical. Thanks for responding. I just need
    to figure out how to ground my element (another thread) and I hope to brew this weekend. Thanks
    again!

  • Posted in thread: Ground Position, Please verify on 03-28-2013 at 11:57 PM
    By the way, I was thinking I would have to remove the outside washer for the ground to be
    proper. Not familiar with electrical, but good at following directions!

0 COMMENTS
POST A COMMENT