VIEW MY

salty_dog_68

Gift Premium Subscription To salty_dog_68

Join Date:

08-23-2012

Last Activity:

04-16-2014 3:28 AM

Likes Given: 8

LATEST ACTIVITY

  • Posted in thread: Grain storage problem at the LHBS? on 04-17-2014 at 12:04 AM
    I was thinking along the line of what you mentioned. Just old and/or stale grains. Located in
    Florida, the temperature at which things are stored is always a concern also. Probably just a
    coincidence ...

  • Posted in thread: The suspense is killing me! (I have the patience of a gnat on crack) on 04-16-2014 at 04:32 AM
    It is already to hot ferment in the hallway of my house here in Florida. So, I ordered my
    STC-1000 the first of April. I found my craigslist freezer and now I am waiting, and waiting,
    still no sign of...

  • Posted in thread: Grain storage problem at the LHBS? on 04-16-2014 at 04:15 AM
    I have a tannin problem. I am new to al grain brewing but I did do partial mashes for a year
    before jumping to all grain. I did not notice a tannin(chalky aftertaste) problem in my partial
    mashes but ...

  • Posted in thread: How to: dry hopping?? on 03-12-2014 at 12:49 AM
    185224I tried dry hopping an IPA for the first time using 1 oz of fuggle leaf hops and a muslin
    bag. I fermented in a bucket/primary for two weeks and then racked over the hops in a carboy.
    It was a p...

  • Posted in thread: Pumpkin Patch Ale on 02-13-2014 at 03:33 PM
    The pumpkin flavor is very subtle. I would say 2.5 - 3. The pumpkin pie spice is a little more
    bold and you get it on the back end(along with the flavor of the aroma hop). I think the
    Amarillo hop pai...

  • Posted in thread: canned/processed yeast starter not working!?!? on 01-16-2014 at 03:46 PM
    Okay! Thanks for all the input and links. Rehydrated dry yeast for most of my brewing and save
    the canned starters for when I want to use liquid yeast. One more quick/generalized question
    while we are...

  • Posted in thread: canned/processed yeast starter not working!?!? on 01-15-2014 at 12:11 PM
    Ty!

  • Posted in thread: canned/processed yeast starter not working!?!? on 01-15-2014 at 04:42 AM
    I think I have a good plan to put in action...process: water in the pint jars, wort in the
    quart jars, and sterilize the 64oz jars. rehydrate the yeast in the pint of sterile water and
    then pour both ...

  • Posted in thread: canned/processed yeast starter not working!?!? on 01-15-2014 at 04:34 AM
    Thanks for the input! Very valuable! I will start rehydrating the yeast before pouring into the
    starter.

  • Posted in thread: canned/processed yeast starter not working!?!? on 01-11-2014 at 05:08 PM
    I have an acetaldehyde problem that I am trying to get a handle on. Several of my recent
    batches are contaminated and I believe that I am not getting good fermentation. I have been
    only rehydrating th...

0 COMMENTS
POST A COMMENT