Gift Premium Subscription To Hinezer

Join Date:


Last Activity:

11-15-2015 4:45 AM

2 Likes on 2 Posts 


  • Posted in thread: Phoenix / Goodyear brewers? on 11-15-2015 at 04:45 AM
    It turned out okay, I think mostly it wasn't what I was expecting from the recipe. I think some
    bottle conditioning will help mellow it out a bit, a little spicy for me. The CFC you have is
    very simil...

  • Posted in thread: Phoenix / Goodyear brewers? on 11-11-2015 at 08:17 AM
    Goodyear checking in! Just finished a Belgian Saison (interesting) and looking at another brew
    here for xmas.Nice! Saison is one of my favorite styles. I'm gonna be brewing a Saison once I
    get my brew...

  • Posted in thread: Valves Won't Open During Automation! Please Help! on 10-30-2015 at 07:18 AM
    I've been slowing building my modified Brutus 10 and have finally got everything finished or so
    I thought. I plugged in the control panel, the pump plugins work, the PIDs work and seemingly

  • Posted in thread: Phoenix / Goodyear brewers? on 10-16-2015 at 05:16 AM
    Goodyear checkin in!Welcome! I'm in Goodyear too! How long have you been brewing? I haven't
    made anything in a few months but I'm hoping to use my new brewstand before the end of the

  • Posted in thread: Brewstand Tubing and Fittings Setup on 07-11-2015 at 09:30 PM
    I'm finishing up my single tier brewstand and I'm just looking to get a little help with some
    of the finishing steps mainly the fittings for the keggles, pumps and plate chiller. I did a
    simple search...

  • Posted in thread: Phoenix / Goodyear brewers? on 02-15-2014 at 03:08 PM
    Goodyear checking in!

  • Posted in thread: Blueberry Summer Ale on 02-01-2014 at 08:47 AM
    Did you have the centennial addition set as first wort hop? Also have you adjusted the AA%?I
    brewed up a version of this recipe and everyone has loved it! I'm also having the same problem
    with Beersmi...


Newest Threads