VIEW MY

Glock

Gift Premium Subscription To Glock

Join Date:

09-18-2013

Last Activity:

12-23-2014 3:02 PM

Likes Given: 5

    ABOUT ME

  • Sweet Stout
  • American IPA (Lite), American IPA
  • Scotch Ale/Wee Heavy, Irish Red
  • Male
  • Married

LATEST ACTIVITY

  • Posted in thread: RIMS Control Panel Review/Help on 01-07-2014 at 03:32 AM
    Looks like the wiring of the probe for the thermocouple is bad. I wiggled the wire a little
    where it enters the panel and the temperature shot up to 140 which is what the dial thermometer
    read. I'm gu...

  • Posted in thread: RIMS Control Panel Review/Help on 01-07-2014 at 02:16 AM
    I changed nothing. I simply filled the tube with water plugged it into the panel and allowed it
    to heat. No trip, no problem. Well i shouldn't say no problem the K TC hooked up to the
    SYL-2362 hasn't ...

  • Posted in thread: RIMS Control Panel Review/Help on 01-06-2014 at 10:03 PM
    Check the point-point continuity from the plug to the terminal screws/ground on the element and
    make sure the hot/neutral/ground are where you think they are.That is the next plan when I get
    home. I s...

  • Posted in thread: RIMS Control Panel Review/Help on 01-06-2014 at 08:56 PM
    ahhhh, open circuit.All I can think of is a stray wire and when you removed the JB weld it
    moved the wire. Is it still tripping the GFCI?I'm confused now (or have been) Don't I want the
    reading to be ...

  • Posted in thread: RIMS Control Panel Review/Help on 01-06-2014 at 05:39 AM
    ahhhh, open circuit.All I can think of is a stray wire and when you removed the JB weld it
    moved the wire. Is it still tripping the GFCI?Yes after JB Weld was removed I tried it again
    and it still tri...

  • Posted in thread: RIMS Control Panel Review/Help on 01-06-2014 at 03:20 AM
    Sorry but what do you mean by "or actually 1"?Sorry it doesn't say 1 it's the default symbol
    "|" when the meter is turned on. So there is no reading when hot or neutral to ground

  • Posted in thread: RIMS Control Panel Review/Help on 01-06-2014 at 02:47 AM
    Ohms read 13.8 when connected to hot and neutral. No reading or actually 1 when hot to ground
    or neutral to ground. The panel reading is 230 with all the switches closed. Thoughts?

  • Posted in thread: RIMS Control Panel Review/Help on 01-05-2014 at 06:21 PM
    He's not pulling anywhere near 20amps but that doesn't trip a GFCI anyway.Did you say you
    potted the electrical with JB weld? That makes it hard to troubleshoot.The JB Weld is now
    removed. I took apar...

  • Posted in thread: RIMS Control Panel Review/Help on 01-05-2014 at 06:18 PM
    Not related to the GFCI issue but is your main power switch rated for 20 amps @ 120V AC?Most
    are rated for 5-10 amps.These are the switches that were recommended, so I used them. I thought
    of that amp...

  • Posted in thread: RIMS Control Panel Review/Help on 12-27-2013 at 10:49 PM
    Ok, so in trying to eliminate the problem I finally just filled the RIMS tube with water and
    plugged it straight into the GFCI outlet I plan on using for the brew rig. Not the smartest
    idea I know but...

0 COMMENTS
POST A COMMENT

Newest Threads

LATEST SPONSOR DEALS