VIEW MY

dirtvet

Gift Premium Subscription To dirtvet

Join Date:

11-10-2009

Last Activity:

01-30-2010 4:12 PM

    ABOUT ME

  • hawthorne, nj
  • Female
  • Single

LATEST ACTIVITY

  • Posted in thread: what did i do wrong on 11-18-2009 at 12:15 AM
    that explains it and makes me feel much better, i topped it off so it must not have been mixed,
    thanks

  • Posted in thread: what did i do wrong on 11-17-2009 at 11:20 PM
    sorry, forgot that part, it was 1.020, way off, it was a brewer's best english brown ale kit, i
    followed the directions or at least think i did, temp was 80

  • Posted in thread: what did i do wrong on 11-17-2009 at 11:10 PM
    hey, i just finished brewing my second batch, was a kit, i thought everything was going fine
    until i took my initial SG reading--was supposed to be 1.040-1.048, obviously did something
    very wrong, onl...

  • Posted in thread: should i be worried? on 11-10-2009 at 08:25 PM
    brewed my first batch 2 days ago and was bubbling well initially but has stopped. i posted
    earlier and someone said to check the gravity as fermentation may be done already. the gravity
    was 1.012 (1.0...

  • Posted in thread: primary fermentation in bottling bucket on 11-10-2009 at 03:16 PM
    i just started my first ever batch 2 days ago and didn't exactly follow the directions. instead
    of putting my wort into my carboy i put it in the bottling bucket for primary fermentation.
    what's the b...

0 COMMENTS
POST A COMMENT