VIEW MY

czucker

Gift Premium Subscription To czucker

Join Date:

06-16-2008

Last Activity:

05-02-2016 4:33 PM

    ABOUT ME

  • Female
  • Single

LATEST ACTIVITY

  • Posted in thread: Size brew kettle for 10 gallon all grain batches,,, on 04-28-2016 at 06:21 PM
    I would go with 15 gallons. A 20 gallon kettle is just too damned big for me.I currently do
    10-12 gallon batches using a 10 gallon boilermaker by using some DME and diluting with
    distilled water at pi...

  • Posted in thread: Sour Mash Questions on 04-28-2016 at 06:14 PM
    Hi Folks,I am planning on trying my first sour in the next few weeks and am attempting to pin
    down my process.My plan right now is to do a small mash in a 1 gallon wide mouth jar with about
    20% of my ...

  • Posted in thread: Two week cask conditioned brew. . . on 03-02-2011 at 03:56 PM
    I have a cask event coming up in two weeks and the beer I was going to serve didn't come out
    quite how I wanted.Can anybody suggest a good style that I can get ready and carbed in two
    weeks?Something ...

  • Posted in thread: Help! My chugger pump just isn't working out. . . on 01-28-2011 at 06:12 PM
    It is admittedly a pain in the ass to make sure there is no air trapped in the dip tube. . .I
    was having the same issues with or without it though.

  • Posted in thread: Help! My chugger pump just isn't working out. . . on 01-27-2011 at 08:56 PM
    I spoke to Mike at Chugger Pumps and he is sending me a new head to try out.He also mentioned
    that it could be a problem with the quick disconnects that I'm using. Everything in my system
    is 1/2", but...

  • Posted in thread: Help! My chugger pump just isn't working out. . . on 01-27-2011 at 05:37 PM
    So I've done some more investigation and it turns out the pump will work if I orient the entire
    pump so the head is on top. When it is oriented horizontally, the impeller just doesn't seem to
    spin.Loo...

  • Posted in thread: Help! My chugger pump just isn't working out. . . on 01-25-2011 at 06:57 PM
    Yes, I have a dip tube in both my kettle and my HLT.

  • Posted in thread: Help! My chugger pump just isn't working out. . . on 01-25-2011 at 06:55 PM
    Hmmmm. . . I just purchased it new and it was the first time I used it.When I remove the head I
    can see that the motor is spinning. I suppose the impeller could be jammed.I will check that
    out tonight...

  • Posted in thread: Help! My chugger pump just isn't working out. . . on 01-25-2011 at 06:10 PM
    Not one of the 150+ people who looked at this have any wisdom to impart?

  • Posted in thread: Help! My chugger pump just isn't working out. . . on 01-24-2011 at 07:09 PM
    I actually had the autovent where the outlet is when I began. . . I was having problems so I
    switched it to the configuration above.I was having a hell of a time either way I tried it.

0 COMMENTS
POST A COMMENT